# CVE-2026-36341: Webkul Krayin CRM is Vulnerable to Cross-Site Scripting in the /admin/activities/create endpoint

> Attackers can inject malicious scripts via the comment field in activity creation, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 May 2026
- **Updated:** 7 May 2026
- **Also known as:** GHSA-j822-46r5-h4qx

## What is CVE-2026-36341?

CVE-2026-36341 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-Site Scripting (XSS) vulnerability exists in Webkul Krayin CRM v2.1.5. The application fails to sanitize user-supplied input in the comment field during Activity creation on the /admin/activities/create endpoint

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-36341?

2 open source packages ship an affected version, including krayin/laravel-crm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `krayin/laravel-crm` | Packagist | From 2.1.5 | 2.1.6 |
| `krayin/laravel-crm` | Packagist | From 2.1.5 | 2.1.6 |

## How do I fix CVE-2026-36341?

Upgrade krayin/laravel-crm to 2.1.6 or later.

## Is CVE-2026-36341 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-36341 exists.

Public exploit code:

- Cross-Site Scripting (XSS) vulnerability exists in Webkul Krayin CRM (HTML Injection) (github_poc): https://github.com/cybercrewinc/CVE-2026-36341

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-36341 and fix it if it is affected.

What it is: CVE-2026-36341 is a medium-severity cross-site scripting vulnerability in n/a, published on 7 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-36341 exists.

Affected packages and fixed versions:
- krayin/laravel-crm (Packagist): affected from 2.1.5; fixed in 2.1.6
- krayin/laravel-crm (Packagist): affected from 2.1.5; fixed in 2.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-36341/ (Markdown: https://insights.sbomify.com/CVE-2026-36341/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-36341
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-36341
- OSV: https://osv.dev/vulnerability/CVE-2026-36341

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-36341/
Summaries are generated and may contain mistakes; the official description above is the record.
