# CVE-2026-3635: fastify: request.protocol and request.host Spoofable via X-Forwarded-Proto/Host from Untrusted Connections

> Attackers can spoof protocol and host headers in Fastify when restrictive trustProxy settings are used, bypassing security checks like HTTPS enforcement.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Mar 2026
- **Updated:** 23 Mar 2026
- **Also known as:** CLSA-2026-1786387037, GHSA-444r-cwp2-x5xf, MINI-546q-564w-xhxv

## What is CVE-2026-3635?

CVE-2026-3635 is a medium-severity vulnerability in fastify, published on 23 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Summary
When trustProxy is configured with a restrictive trust function (e.g., a specific IP like trustProxy: '10.0.0.1', a subnet, a hop count, or a custom function), the request.protocol and request.host getters read X-Forwarded-Proto and X-Forwarded-Host headers from any connection — including connections from untrusted IPs. This allows an attacker connecting directly to Fastify (bypassing the proxy) to spoof both the protocol and host seen by the application.

Affected Versions
fastify <= 5.8.2

Impact
Applications using request.protocol or request.host for security decisions (HTTPS enforcement, secure cookie flags, CSRF origin checks, URL construction, host-based routing) are affected when trustProxy is configured with a restrictive trust function.

When trustProxy: true (trust everything), both host and protocol trust all forwarded headers — this is expected behavior. The vulnerability only manifests with restrictive trust configurations.

Weakness: CWE-348 (Use of Less Trusted Source)

## Which versions are affected by CVE-2026-3635?

2 open source packages ship an affected version, including fastify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify` | npm | All versions | 5.8.3 |
| `fastify` | npm | All versions | 5.8.3 |

Products: Fastify Fastify.

## How do I fix CVE-2026-3635?

Upgrade fastify to 5.8.3 or later.

## Is CVE-2026-3635 being exploited?

There is no known exploitation of CVE-2026-3635 in the wild and no public exploit code.

## Other vulnerabilities in fastify

- [CVE-2026-84504](https://insights.sbomify.com/CVE-2026-84504/): fastify vulnerable to request body replacement via an async validation result collision (high 8.1)
- [CVE-2026-76169](https://insights.sbomify.com/CVE-2026-76169/): fastify vulnerable to authentication bypass via malformed URLs reaching encapsulated not-found handlers (high 7.5)
- [CVE-2026-84428](https://insights.sbomify.com/CVE-2026-84428/): fastify vulnerable to header validation bypass via incomplete schema case normalization (high 7.5)
- [CVE-2026-84469](https://insights.sbomify.com/CVE-2026-84469/): fastify vulnerable to request validation bypass via skipped boolean false schemas (high 7.5)
- [CVE-2026-33806](https://insights.sbomify.com/CVE-2026-33806/): fastify vulnerable to Body Schema Validation Bypass via Leading Space in Content-Type Header (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3635 and fix it if it is affected.

What it is: CVE-2026-3635 is a medium-severity vulnerability in fastify, published on 23 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-3635 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify (npm): affected all versions; fixed in 5.8.3
- fastify (npm): affected all versions; fixed in 5.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3635/ (Markdown: https://insights.sbomify.com/CVE-2026-3635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3635
- OSV: https://osv.dev/vulnerability/CVE-2026-3635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3635/
Summaries are generated and may contain mistakes; the official description above is the record.
