CVE-2026-3636 Sanitize team member data returned by API
Attackers can retrieve sensitive team member role data via API endpoints without elevated permissions, exposing internal user roles.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-3636?
CVE-2026-3636 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 22 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to sanitize team member data when returned via API to users without elevated permissions which allows a user without permissions to get data about team members roles via invoking various team API endpoints.. Mattermost Advisory ID: MMSA-2026-00626
Weakness: CWE-200
Which versions are affected by CVE-2026-3636?
9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.15 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.15 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.15+incompatible, 11.4.5+incompatible, 11.5.4+incompatible, 11.6.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.5 |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.5 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.4 |
3 more packages
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.4 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-3636?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.15, 10.11.15+incompatible, 11.4.5+incompatible or 11.5.4+incompatible.
Is CVE-2026-3636 being exploited?
There is no known exploitation of CVE-2026-3636 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-ffpr-pfr4-g354, GO-2026-5818.