CVE-2026-3637 Mattermost fails to enforce create_post permission when editing posts
Authenticated attackers with revoked posting privileges can modify existing posts via API requests due to missing permission checks.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-3637?
CVE-2026-3637 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 18 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 11.5.x <= 11.5.1, 10.11.x <= 10.11.13, 11.4.x <= 11.4.3 fail to check the create_post channel permission during post edit operations which allows an authenticated attacker with revoked posting privileges to modify their existing posts via direct API requests to the post update and patch endpoints.. Mattermost Advisory ID: MMSA-2026-00627
Weakness: CWE-862
Which versions are affected by CVE-2026-3637?
14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260316171743-090408f09f53 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260316171743-090408f09f53 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20260316171743-090408f09f53 |
github.com/mattermost/mattermost/server/v8 Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost/server/v8 Go | From 10.11.0 | 10.11.14 |
github.com/mattermost/mattermost/server/v8 Go | From 11.4.0 | 11.4.4 |
8 more packages
github.com/mattermost/mattermost/server/v8 Go | From 11.4.0 | 11.4.4 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 11.5.0 | 11.5.2 |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260316171743-090408f09f53 |
github.com/mattermost/mattermost-server Go | All versions | 5.3.2-0.20260316171743-090408f09f53 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.14+incompatible, 11.4.4+incompatible, 11.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-3637?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20260316171743-090408f09f53, 10.11.14, 11.4.4 or 11.5.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-3637 being exploited?
There is no known exploitation of CVE-2026-3637 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-v549-xx3c-6pc8, GO-2026-5651.