{"answers":{"affected":"3 open source packages ship an affected version, including litellm.","exploited":"There is no known exploitation of CVE-2026-37004 in the wild and no public exploit code.","fix":"Upgrade litellm to 1.83.7 or later.","what":"CVE-2026-37004 is a critical code injection vulnerability in n/a, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-37004 and fix it if it is affected.\n\nWhat it is: CVE-2026-37004 is a critical code injection vulnerability in n/a, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-37004 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.83.7\n- litellm (PyPI): affected all versions; fixed in 1.83.7\n- litellm (PyPI): affected all versions; fixed in 1.83.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-37004/ (Markdown: https://insights.sbomify.com/CVE-2026-37004/index.md)","id":"CVE-2026-37004","markdown":"https://insights.sbomify.com/CVE-2026-37004/index.md","name":"CVE-2026-37004","record":{"aliases":["ECHO-a062-523f-e726","GHSA-6wvf-77m9-58rm","MINI-79gg-82x6-83mm","MINI-7mmg-h5fw-q8pf","MINI-9j6v-jprr-rjq9","MINI-qwhw-vf95-r25r","MINI-wp7q-x63v-qm7g","MINI-x2fp-x38p-6r92","PYSEC-2026-3861"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LiteLLM Python library","requires_auth":"none","summary":"Unauthenticated attackers can execute arbitrary OS commands via Server-Side Template Injection in the LiteLLM library's prompt testing endpoint.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-1336","name":"Improper Neutralization of Special Elements Used in a Template Engine"}],"description":"BerriAI litellm \u003c=1.82.4 is vulnerable to Server-Side Template Injection (SSTI), which allows unauthenticated remote attackers to execute arbitrary OS commands via a crafted dotprompt_content parameter in the /prompts/test endpoint due to use of an unsandboxed jinja2.Environment.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"LiteLLM vulnerable to server-side template injection in the /prompts/test endpoint","id":"CVE-2026-37004","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Code injection in n/a","id":"CVE-2026-37006"},"packages":[{"ecosystem":"PyPI","fixed":["1.83.7"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-6wvf-77m9-58rm"},{"ecosystem":"PyPI","fixed":["1.83.7"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-6wvf-77m9-58rm"},{"ecosystem":"PyPI","fixed":["1.83.7"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-3861"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2026-37003"},"products":["n/a"],"published":"2026-08-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-01","vendors":["n/a"]},"summary":"Unauthenticated attackers can execute arbitrary OS commands via Server-Side Template Injection in the LiteLLM library's prompt testing endpoint.","url":"https://insights.sbomify.com/CVE-2026-37004/"}