# CVE-2026-37004: LiteLLM vulnerable to server-side template injection in the /prompts/test endpoint

> Unauthenticated attackers can execute arbitrary OS commands via Server-Side Template Injection in the LiteLLM library's prompt testing endpoint.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Aug 2026
- **Updated:** 1 Sep 2026
- **Also known as:** ECHO-a062-523f-e726, GHSA-6wvf-77m9-58rm, MINI-79gg-82x6-83mm, MINI-7mmg-h5fw-q8pf, MINI-9j6v-jprr-rjq9, MINI-qwhw-vf95-r25r, MINI-wp7q-x63v-qm7g, MINI-x2fp-x38p-6r92, PYSEC-2026-3861

## What is CVE-2026-37004?

CVE-2026-37004 is a critical code injection vulnerability in n/a, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

BerriAI litellm <=1.82.4 is vulnerable to Server-Side Template Injection (SSTI), which allows unauthenticated remote attackers to execute arbitrary OS commands via a crafted dotprompt_content parameter in the /prompts/test endpoint due to use of an unsandboxed jinja2.Environment.

Weakness: CWE-1336 (Improper Neutralization of Special Elements Used in a Template Engine)

## Which versions are affected by CVE-2026-37004?

3 open source packages ship an affected version, including litellm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `litellm` | PyPI | All versions | 1.83.7 |
| `litellm` | PyPI | All versions | 1.83.7 |
| `litellm` | PyPI | All versions | 1.83.7 |

## How do I fix CVE-2026-37004?

Upgrade litellm to 1.83.7 or later.

## Is CVE-2026-37004 being exploited?

There is no known exploitation of CVE-2026-37004 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-37004 and fix it if it is affected.

What it is: CVE-2026-37004 is a critical code injection vulnerability in n/a, published on 27 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-37004 in the wild and no public exploit code.

Affected packages and fixed versions:
- litellm (PyPI): affected all versions; fixed in 1.83.7
- litellm (PyPI): affected all versions; fixed in 1.83.7
- litellm (PyPI): affected all versions; fixed in 1.83.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-37004/ (Markdown: https://insights.sbomify.com/CVE-2026-37004/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-37004
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-37004
- OSV: https://osv.dev/vulnerability/CVE-2026-37004

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-37004/
Summaries are generated and may contain mistakes; the official description above is the record.
