{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-37458 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-37458 is a medium-severity denial of service vulnerability in n/a, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-37458 and fix it if it is affected.\n\nWhat it is: CVE-2026-37458 is a medium-severity denial of service vulnerability in n/a, published on 4 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-37458 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-37458/ (Markdown: https://insights.sbomify.com/CVE-2026-37458/index.md)","id":"CVE-2026-37458","markdown":"https://insights.sbomify.com/CVE-2026-37458/index.md","name":"CVE-2026-37458","record":{"aliases":["AZL-86214","DEBIAN-CVE-2026-37458","GHSA-m357-6hwr-7w53","SUSE-SU-2026:3868-1","UBUNTU-CVE-2026-37458"],"analysis":{"component_type":"network_device","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"FRRouting network stack","requires_auth":"low_privilege","summary":"Authenticated attackers can cause a Denial of Service in FRRouting by sending a crafted UPDATE message due to missing input validation in MP_REACH_NLRI.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"frrouting","vendor":"frrouting"}],"cvss":{"score":6.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Missing input validation in the MP_REACH_NLRI component of FRRouting (FRR) stable/10.0 to stable/10.6 allows authenticated attackers to cause a Denial of Service (DoS) via supplying a crafted UPDATE message.","ecosystems":["SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2026-37458","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Integer overflow in n/a","id":"CVE-2026-37459"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["1.1.1-17.16.1"],"introduced":["0"],"last_affected":[],"package":"quagga","purl":"pkg:rpm/suse/quagga\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2026:3868-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2026-37457"},"products":["n/a"],"published":"2026-05-04","related":[{"cvss_score":9.8,"headline":"Denial of service in n/a","id":"CVE-2024-44070","kev_date_added":null,"published":"2024-08-19"},{"cvss_score":9.8,"headline":"bgpd/bgp_flowspec.c in FRRouting (FRR) before 8.4.3 mishandles an nlri length of zero, aka a \"flowspec overflow.\"","id":"CVE-2023-38406","kev_date_added":null,"published":"2023-11-06"},{"cvss_score":8.1,"headline":"Use after free in n/a","id":"CVE-2022-37035","kev_date_added":null,"published":"2022-08-02"},{"cvss_score":7.8,"headline":"Memory corruption in FRRouting","id":"CVE-2022-26127","kev_date_added":null,"published":"2022-03-03"},{"cvss_score":7.8,"headline":"Memory corruption in FRRouting","id":"CVE-2022-26128","kev_date_added":null,"published":"2022-03-03"},{"cvss_score":7.8,"headline":"Memory corruption in FRRouting","id":"CVE-2022-26129","kev_date_added":null,"published":"2022-03-03"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2026-37457","kev_date_added":null,"published":"2026-05-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-05-05","vendors":["n/a"]},"summary":"Authenticated attackers can cause a Denial of Service in FRRouting by sending a crafted UPDATE message due to missing input validation in MP_REACH_NLRI.","url":"https://insights.sbomify.com/CVE-2026-37458/"}