# CVE-2026-37461: GoBGP has an out-of-bounds read in the ParseIP6Extended function

> Attackers can cause a Denial of Service in gobgp by sending a crafted BGP UPDATE message that triggers an out-of-bounds read.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 May 2026
- **Updated:** 5 May 2026
- **Also known as:** DEBIAN-CVE-2026-37461, GHSA-wmvj-f67g-qg4g, GO-2026-5713, UBUNTU-CVE-2026-37461

## What is CVE-2026-37461?

CVE-2026-37461 is a high-severity denial of service vulnerability in n/a, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An out-of-bounds read in the ParseIP6Extended function (/bgp/bgp.go) of gobgp v4.3.0 allows attackers to cause a Denial of Service (DoS) via supplying a crafted BGP UPDATE message.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2026-37461?

3 open source packages ship an affected version, including github.com/osrg/gobgp/v4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.4.0 |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.4.0 |
| `github.com/osrg/gobgp/v4` | Go | All versions | 4.4.0 |

Products: Osrg Gobgp.

## How do I fix CVE-2026-37461?

Upgrade github.com/osrg/gobgp/v4 to 4.4.0 or later.

## Is CVE-2026-37461 being exploited?

There is no known exploitation of CVE-2026-37461 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-43971](https://insights.sbomify.com/CVE-2025-43971/): GoBGP panics due to a zero value for softwareVersionLen (high 8.6)
- [CVE-2026-41642](https://insights.sbomify.com/CVE-2026-41642/): GoBGP: Remote Denial of Service (Panic) via Malformed Well-known Path Attribute (high 7.5)
- [CVE-2026-41643](https://insights.sbomify.com/CVE-2026-41643/): GoBGP: Remote Denial of Service (Panic) in UpdatePathAttrs4ByteAs via Malformed BGP UPDATE (high 7.5)
- [CVE-2026-42285](https://insights.sbomify.com/CVE-2026-42285/): GoBGP: Panic in AdjRib.Update via malformed BGP Update message (Nil Pointer Dereference) (high 7.5)
- [CVE-2026-30405](https://insights.sbomify.com/CVE-2026-30405/): GoBGP vulnerable to a denial of service via the NEXT_HOP path attribute (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-37461 and fix it if it is affected.

What it is: CVE-2026-37461 is a high-severity denial of service vulnerability in n/a, published on 4 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-37461 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0
- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-37461/ (Markdown: https://insights.sbomify.com/CVE-2026-37461/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-37461
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-37461
- OSV: https://osv.dev/vulnerability/CVE-2026-37461

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-37461/
Summaries are generated and may contain mistakes; the official description above is the record.
