{"answers":{"affected":"3 open source packages ship an affected version, including github.com/osrg/gobgp/v4.","exploited":"There is no known exploitation of CVE-2026-37462 in the wild and no public exploit code.","fix":"Upgrade github.com/osrg/gobgp/v4 to 4.4.0 or later.","what":"CVE-2026-37462 is a high-severity vulnerability in n/a, published on 3 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-37462 and fix it if it is affected.\n\nWhat it is: CVE-2026-37462 is a high-severity vulnerability in n/a, published on 3 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-37462 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0\n- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0\n- github.com/osrg/gobgp/v4 (Go): affected all versions; fixed in 4.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-37462/ (Markdown: https://insights.sbomify.com/CVE-2026-37462/index.md)","id":"CVE-2026-37462","markdown":"https://insights.sbomify.com/CVE-2026-37462/index.md","name":"CVE-2026-37462","record":{"aliases":["DEBIAN-CVE-2026-37462","GHSA-pw7p-7fqv-hpj8","GO-2026-5971","UBUNTU-CVE-2026-37462"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Go BGP library","requires_auth":"none","summary":"Attackers can cause a Denial of Service in the gobgp library by sending a crafted BGP UPDATE message that triggers an integer underflow.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"An integer underflow in the BGPUpdate.DecodeFromBytes function (/bgp/bgp.go) of gobgp v4.3.0 allows attackers to cause a Denial of Service (DoS) via supplying a crafted BGP UPDATE message.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GoBGP: Integer underflow in the BGPUpdate.DecodeFromBytes function","id":"CVE-2026-37462","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2026-37470"},"packages":[{"ecosystem":"Go","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v4","purl":null,"source":"GHSA-pw7p-7fqv-hpj8"},{"ecosystem":"Go","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v4","purl":"pkg:golang/github.com/osrg/gobgp/v4","source":"GHSA-pw7p-7fqv-hpj8"},{"ecosystem":"Go","fixed":["4.4.0"],"introduced":["0"],"last_affected":[],"package":"github.com/osrg/gobgp/v4","purl":"pkg:golang/github.com/osrg/gobgp/v4","source":"GO-2026-5971"}],"prev":{"headline":"GoBGP has an out-of-bounds read in the ParseIP6Extended function","id":"CVE-2026-37461"},"products":["n/a"],"published":"2026-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-04","vendors":["n/a"]},"summary":"Attackers can cause a Denial of Service in the gobgp library by sending a crafted BGP UPDATE message that triggers an integer underflow.","url":"https://insights.sbomify.com/CVE-2026-37462/"}