# CVE-2026-37978: Keycloak: org.keycloak.services: keycloak: information disclosure via evaluate-scopes admin api

> Low-privilege administrators can leak user PII and authorization data via the evaluate-scopes Admin API endpoint.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 20 May 2026
- **Also known as:** BIT-keycloak-2026-37978, ECHO-e419-5755-0224, GHSA-rrv7-3mqf-hxfr, MINI-3444-357q-3jx2, MINI-m26c-jrm7-jp83

## What is CVE-2026-37978?

CVE-2026-37978 is a medium-severity vulnerability in Redhat Build of Keycloak, published on 19 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A flaw was found in Keycloak. A low-privilege administrator with the 'view-clients' role can exploit this by invoking the 'evaluate-scopes' Admin API endpoints with an arbitrary user ID (userId) parameter. This vulnerability allows for cross-role personally identifiable information (PII) leakage, enabling unauthorized visibility into user identities and authorizations across the realm. Exploitation is possible remotely via network access to the Admin API.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-37978?

3 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.2 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.2 |
| `keycloak` | Bitnami | All versions | 26.4.12 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-37978?

Upgrade org.keycloak:keycloak-services to 26.6.2 or later.

## Is CVE-2026-37978 being exploited?

There is no known exploitation of CVE-2026-37978 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-37978 and fix it if it is affected.

What it is: CVE-2026-37978 is a medium-severity vulnerability in Redhat Build of Keycloak, published on 19 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-37978 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.2
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.2
- keycloak (Bitnami): affected all versions; fixed in 26.4.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-37978/ (Markdown: https://insights.sbomify.com/CVE-2026-37978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-37978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-37978
- OSV: https://osv.dev/vulnerability/CVE-2026-37978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-37978/
Summaries are generated and may contain mistakes; the official description above is the record.
