{"answers":{"affected":"3 open source packages ship an affected version, including dash-uploader.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-38360 exists.","fix":"No fix has been published for CVE-2026-38360 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-38360 is a critical path traversal vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-38360 and fix it if it is affected.\n\nWhat it is: CVE-2026-38360 is a critical path traversal vulnerability in n/a, published on 8 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-38360 exists.\n\nAffected packages and fixed versions:\n- dash-uploader (PyPI): affected from 0.1.0 up to 0.7.0a2; no fix listed\n- dash-uploader (PyPI): affected from 0.1.0 up to 0.7.0a2; no fix listed\n- dash-uploader (PyPI): affected from 0.1.0 up to 0.7.0a2; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-38360/ (Markdown: https://insights.sbomify.com/CVE-2026-38360/index.md)","id":"CVE-2026-38360","markdown":"https://insights.sbomify.com/CVE-2026-38360/index.md","name":"CVE-2026-38360","record":{"aliases":["GHSA-3rf6-x59v-5jfv","PYSEC-2026-320"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python dash uploader","requires_auth":"none","summary":"A remote attacker can execute arbitrary code via a directory traversal vulnerability in the dash-uploader Python library.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory Traversal vulnerability in fohrloop dash-uploader v.0.1.0 through v.0.7.0a2 allows a remote attacker to execute arbitrary code via the dash_uploader/httprequesthandler.py, BaseHttpRequestHandler.get_temp_root(), BaseHttpRequestHandler._post() components.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2026-05-07","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":1,"refs":[{"date":"2026-05-07T20:32:41Z","kind":"github_poc","ref":"https://github.com/a1ohadance/CVE-2026-38360","stars":2,"title":"Advisory: CVE-2026-38360 path traversal (CWE-22) in dash-uploader (Python/PyPI)"},{"date":null,"kind":"nuclei","ref":"http/cves/2026/CVE-2026-38360.yaml","stars":null,"title":"dash-uploader 0.1.0 - 0.7.0a2 - Unauthenticated Arbitrary File Write via Path Traversal"}],"tier":"weaponised"},"has_fix":false,"headline":"dash-uploader has a directory traversal vulnerability","id":"CVE-2026-38360","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":8,"next":{"headline":"Denial of service in n/a","id":"CVE-2026-38361"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0.1.0"],"last_affected":["0.7.0a2"],"package":"dash-uploader","purl":null,"source":"GHSA-3rf6-x59v-5jfv"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.1.0"],"last_affected":["0.7.0a2"],"package":"dash-uploader","purl":"pkg:pypi/dash-uploader","source":"GHSA-3rf6-x59v-5jfv"},{"ecosystem":"PyPI","fixed":[],"introduced":["0.1.0"],"last_affected":["0.7.0a2"],"package":"dash-uploader","purl":"pkg:pypi/dash-uploader","source":"PYSEC-2026-320"}],"prev":{"headline":"Integer overflow in n/a","id":"CVE-2026-38350"},"products":["n/a"],"published":"2026-05-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-06-10","vendors":["n/a"]},"summary":"A remote attacker can execute arbitrary code via a directory traversal vulnerability in the dash-uploader Python library.","url":"https://insights.sbomify.com/CVE-2026-38360/"}