# CVE-2026-38728: smtp-server's command parser memory exhaustion denial-of-service

> A remote attacker can cause a denial of service in Nodemailer smtp_server via the SMTPStream._write component.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 May 2026
- **Updated:** 15 May 2026
- **Also known as:** GHSA-fv2f-rw9f-v9cm

## What is CVE-2026-38728?

CVE-2026-38728 is a high-severity denial of service vulnerability in n/a, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue in Nodemailer smtp_server before v.3.18.3 allows a remote attacker to cause a denial of service via the SMTPStream._write, lib/smtp-stream.js components

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-38728?

2 open source packages ship an affected version, including smtp-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `smtp-server` | npm | All versions | 3.18.3 |
| `smtp-server` | npm | All versions | 3.18.3 |

## How do I fix CVE-2026-38728?

Upgrade smtp-server to 3.18.3 or later.

## Is CVE-2026-38728 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-38728 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-38728 and fix it if it is affected.

What it is: CVE-2026-38728 is a high-severity denial of service vulnerability in n/a, published on 15 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-38728 exists.

Affected packages and fixed versions:
- smtp-server (npm): affected all versions; fixed in 3.18.3
- smtp-server (npm): affected all versions; fixed in 3.18.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-38728/ (Markdown: https://insights.sbomify.com/CVE-2026-38728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-38728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-38728
- OSV: https://osv.dev/vulnerability/CVE-2026-38728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-38728/
Summaries are generated and may contain mistakes; the official description above is the record.
