# CVE-2026-38743: Apache Airflow: Dags endpoint might provide access to otherwise inaccessible entities

> Authenticated users can access unauthorized DAG data, including HITL prompts and task details, due to missing per-DAG access controls.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** BIT-airflow-2026-38743, ECHO-4594-a85c-c06f, GHSA-p3v3-229h-mc63, MINI-7f6p-mvh4-ch87, MINI-c797-84mw-mv64, PYSEC-2026-2351

## What is CVE-2026-38743?

CVE-2026-38743 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The authenticated /ui/dags endpoint did not enforce per-DAG access control on embedded Human-in-the-Loop (HITL) and TaskInstance records: a logged-in Airflow user with read access to at least one DAG could retrieve HITL prompts (including their request parameters) and full TaskInstance details for DAGs outside their authorized scope. Because HITL prompts and TaskInstance fields routinely carry operator parameters and free-form context attached to a task, the leak widens visibility of DAG-run data beyond the intended per-DAG RBAC boundary for every authenticated user.

Users are recommended to upgrade to version 3.2.1 , which fixes this issue.

Weakness: CWE-1220 (Insufficient Granularity of Access Control)

## Which versions are affected by CVE-2026-38743?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.2.1rc1 |
| `apache-airflow` | PyPI | All versions | 3.2.1rc1 |
| `apache-airflow` | PyPI | All versions | 3.2.1rc1 |
| `airflow` | Bitnami | All versions | 3.2.1 |

Products: Apache Airflow.

## How do I fix CVE-2026-38743?

Upgrade apache-airflow to 3.2.1rc1 or later.

## Is CVE-2026-38743 being exploited?

There is no known exploitation of CVE-2026-38743 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-38743 and fix it if it is affected.

What it is: CVE-2026-38743 is a medium-severity missing authorization vulnerability in Apache Airflow, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-38743 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.2.1rc1
- apache-airflow (PyPI): affected all versions; fixed in 3.2.1rc1
- apache-airflow (PyPI): affected all versions; fixed in 3.2.1rc1
- airflow (Bitnami): affected all versions; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-38743/ (Markdown: https://insights.sbomify.com/CVE-2026-38743/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-38743
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-38743
- OSV: https://osv.dev/vulnerability/CVE-2026-38743

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-38743/
Summaries are generated and may contain mistakes; the official description above is the record.
