CVE-2026-38991 Cockpit Vulnerable to Unrestricted Upload of File with Dangerous Type

High 8.8 Published Updated

An authenticated attacker can bypass file extension filters to upload PHP files, enabling arbitrary code execution on the server.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-38991?

CVE-2026-38991 is a high-severity vulnerability in n/a, published on 29 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Cockpit 2.13.5 and earlier is affected by a misconfiguration within the Bucket component _isFileTypeAllowed function where a specially crafted filename bypasses an extension filter. This allows an authenticated attacker to rename arbitrary files with the .php file extension enabling arbitrary code to be executed on the underlying server.

Weakness: CWE-434

Which versions are affected by CVE-2026-38991?

2 open source packages ship an affected version, including cockpit-hq/cockpit.

PackageAffectedFixed in
cockpit-hq/cockpit PackagistAll versions2.14.0
cockpit-hq/cockpit PackagistAll versions2.14.0

How do I fix CVE-2026-38991?

Upgrade cockpit-hq/cockpit to 2.14.0 or later.

Is CVE-2026-38991 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-38991 exists.

Sources

Also known as GHSA-j2rx-4jg9-79mw.

Is CVE-2026-38991 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free