# CVE-2026-38991: Cockpit Vulnerable to Unrestricted Upload of File with Dangerous Type

> An authenticated attacker can bypass file extension filters to upload PHP files, enabling arbitrary code execution on the server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Apr 2026
- **Updated:** 29 Apr 2026
- **Also known as:** GHSA-j2rx-4jg9-79mw

## What is CVE-2026-38991?

CVE-2026-38991 is a high-severity vulnerability in n/a, published on 29 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cockpit 2.13.5 and earlier is affected by a misconfiguration within the Bucket component _isFileTypeAllowed function where a specially crafted filename bypasses an extension filter. This allows an authenticated attacker to rename arbitrary files with the .php file extension enabling arbitrary code to be executed on the underlying server.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-38991?

2 open source packages ship an affected version, including cockpit-hq/cockpit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.14.0 |
| `cockpit-hq/cockpit` | Packagist | All versions | 2.14.0 |

## How do I fix CVE-2026-38991?

Upgrade cockpit-hq/cockpit to 2.14.0 or later.

## Is CVE-2026-38991 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-38991 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-38991 and fix it if it is affected.

What it is: CVE-2026-38991 is a high-severity vulnerability in n/a, published on 29 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-38991 exists.

Affected packages and fixed versions:
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.14.0
- cockpit-hq/cockpit (Packagist): affected all versions; fixed in 2.14.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-38991/ (Markdown: https://insights.sbomify.com/CVE-2026-38991/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-38991
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-38991
- OSV: https://osv.dev/vulnerability/CVE-2026-38991

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-38991/
Summaries are generated and may contain mistakes; the official description above is the record.
