CVE-2026-38993 Cockpit is vulnerable to directory traversal

Medium 6.5 Published Updated

Authenticated attackers can exploit a directory traversal flaw in Cockpit CMS to write or overwrite files, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-38993?

CVE-2026-38993 is a medium-severity path traversal vulnerability in n/a, published on 29 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Cockpit 2.13.5 and earlier is vulnerable to directory traversal via the Buckets component. This vulnerability allows authenticated attackers to write files to arbitrary locations within the uploads directory or overwrite assets with malicious versions.

Weakness: CWE-22

Which versions are affected by CVE-2026-38993?

2 open source packages ship an affected version, including cockpit-hq/cockpit.

PackageAffectedFixed in
cockpit-hq/cockpit PackagistAll versions2.14.0
cockpit-hq/cockpit PackagistAll versions2.14.0

How do I fix CVE-2026-38993?

Upgrade cockpit-hq/cockpit to 2.14.0 or later.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2026-38993 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-38993 exists.

Sources

Also known as GHSA-p46p-7pmj-m34f.

Is CVE-2026-38993 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free