{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2026-3906 in the wild and no public exploit code.","fix":"Upgrade wordpress to 6.9.2 or later.","what":"CVE-2026-3906 is a medium-severity missing authorization vulnerability in WordPress, published on 11 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-3906 and fix it if it is affected.\n\nWhat it is: CVE-2026-3906 is a medium-severity missing authorization vulnerability in WordPress, published on 11 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-3906 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 6.9.0; fixed in 6.9.2\n- wordpress-multisite (Bitnami): affected from 6.9.0; fixed in 6.9.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-3906/ (Markdown: https://insights.sbomify.com/CVE-2026-3906/index.md)","id":"CVE-2026-3906","markdown":"https://insights.sbomify.com/CVE-2026-3906/index.md","name":"CVE-2026-3906","record":{"aliases":["BIT-wordpress-2026-3906","BIT-wordpress-multisite-2026-3906","DEBIAN-CVE-2026-3906","GHSA-6x83-fcf5-r65g","MINI-jrj6-w9x2-qr4p","UBUNTU-CVE-2026-3906"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress core","requires_auth":"low_privilege","summary":"Authenticated subscribers can create arbitrary notes on any post via the REST API due to missing permission checks in WordPress core.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"WordPress core is vulnerable to unauthorized access in versions 6.9 through 6.9.1. The Notes feature (block-level collaboration annotations) was introduced in WordPress 6.9 to allow editorial comments directly on posts in the block editor. However, the REST API `create_item_permissions_check()` method in the comments controller did not verify that the authenticated user has `edit_post` permission on the target post when creating a note. This makes it possible for authenticated attackers with Subscriber-level access to create notes on any post, including posts authored by other users, private posts, and posts in any status.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress 6.9 - 6.9.1 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Note Creation via REST API","id":"CVE-2026-3906","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Hostel \u003c= 1.1.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'wphostel-book' Shortcode","id":"CVE-2026-3907"},"packages":[{"ecosystem":"Bitnami","fixed":["6.9.2"],"introduced":["6.9.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2026-3906"},{"ecosystem":"Bitnami","fixed":["6.9.2"],"introduced":["6.9.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2026-3906"}],"prev":{"headline":"Race condition in glibc","id":"CVE-2026-3904"},"products":["WordPress"],"published":"2026-03-11","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-11","vendors":["WordPress Foundation"]},"summary":"Authenticated subscribers can create arbitrary notes on any post via the REST API due to missing permission checks in WordPress core.","url":"https://insights.sbomify.com/CVE-2026-3906/"}