CVE-2026-39304 Apache ActiveMQ: Denial of Service via Out of Memory vulnerability
A remote attacker can cause a Denial of Service via Out of Memory in Apache ActiveMQ by exploiting incorrect TLSv1.3 KeyUpdate handling.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-39304?
CVE-2026-39304 is a high-severity denial of service vulnerability in Apache Activemq, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ.
ActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS.
Note: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well. This issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4.
Users are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.
Which versions are affected by CVE-2026-39304?
17 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.activemq:activemq-all Maven | All versions | 5.19.4 |
org.apache.activemq:activemq-all Maven | All versions | 5.19.4 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.4 |
org.apache.activemq:activemq-all Maven | From 6.0.0 | 6.2.4 |
activemq Bitnami | All versions | 5.19.4, 6.2.4 |
org.apache.activemq:activemq-broker Maven | All versions | 5.19.4 |
11 more packages
org.apache.activemq:activemq-broker Maven | All versions | 5.19.4 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.4 |
org.apache.activemq:activemq-broker Maven | From 6.0.0 | 6.2.4 |
org.apache.activemq:activemq-client Maven | All versions | 5.19.4 |
org.apache.activemq:activemq-client Maven | All versions | 5.19.4 |
org.apache.activemq:activemq-client Maven | From 6.0.0 | 6.2.4 |
org.apache.activemq:activemq-client Maven | From 6.0.0 | 6.2.4 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.4 |
org.apache.activemq:apache-activemq Maven | All versions | 5.19.4 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.4 |
org.apache.activemq:apache-activemq Maven | From 6.0.0 | 6.2.4 |
Products include Apache Activemq, Apache Activemq Broker.
How do I fix CVE-2026-39304?
Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.4 or 6.2.4.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-39304 being exploited?
There is no known exploitation of CVE-2026-39304 in the wild and no public exploit code.
Other vulnerabilities in Apache Activemq
Sources
Also known as BIT-activemq-2026-39304, DEBIAN-CVE-2026-39304, GHSA-5568-6qcg-g7fx, MINI-53rj-m3gh-4p5j, MINI-59xh-9j2x-3wjf, MINI-64ch-98hp-h8w3 and 5 more.