# CVE-2026-39304: Apache ActiveMQ: Denial of Service via Out of Memory vulnerability

> A remote attacker can cause a Denial of Service via Out of Memory in Apache ActiveMQ by exploiting incorrect TLSv1.3 KeyUpdate handling.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Apr 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-activemq-2026-39304, DEBIAN-CVE-2026-39304, GHSA-5568-6qcg-g7fx, MINI-53rj-m3gh-4p5j, MINI-59xh-9j2x-3wjf, MINI-64ch-98hp-h8w3, MINI-cfw9-xq29-57wv, MINI-fgrm-v85g-mj99, MINI-qhmq-jc26-jqmr, ROOT-APP-MAVEN-CVE-2026-39304, UBUNTU-CVE-2026-39304

## What is CVE-2026-39304?

CVE-2026-39304 is a high-severity denial of service vulnerability in Apache Activemq, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Denial of Service via Out of Memory vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ.

ActiveMQ NIO SSL transports do not correctly handle TLSv1.3 handshake KeyUpdates triggered by clients. This makes it possible for a client to rapidly trigger updates which causes the broker to exhaust all its memory in the SSL engine leading to DoS.

Note: TLS versions before TLSv1.3 (such as TLSv1.2) are broken but are not vulnerable to OOM. Previous TLS versions require a full handshake renegotiation which causes a connection to hang but not OOM. This is fixed as well.
This issue affects Apache ActiveMQ Client: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ Broker: before 5.19.4, from 6.0.0 before 6.2.4; Apache ActiveMQ: before 5.19.4, from 6.0.0 before 6.2.4.

Users are recommended to upgrade to version 6.2.4 or 5.19.5, which fixes the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-39304?

17 open source packages ship an affected version, including org.apache.activemq:activemq-all, activemq and org.apache.activemq:activemq-broker. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.4 |
| `org.apache.activemq:activemq-all` | Maven | All versions | 5.19.4 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.4 |
| `org.apache.activemq:activemq-all` | Maven | From 6.0.0 | 6.2.4 |
| `activemq` | Bitnami | All versions | 5.19.4, 6.2.4 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.4 |
| `org.apache.activemq:activemq-broker` | Maven | All versions | 5.19.4 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.4 |
| `org.apache.activemq:activemq-broker` | Maven | From 6.0.0 | 6.2.4 |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.19.4 |
| `org.apache.activemq:activemq-client` | Maven | All versions | 5.19.4 |
| `org.apache.activemq:activemq-client` | Maven | From 6.0.0 | 6.2.4 |
| `org.apache.activemq:activemq-client` | Maven | From 6.0.0 | 6.2.4 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.4 |
| `org.apache.activemq:apache-activemq` | Maven | All versions | 5.19.4 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.4 |
| `org.apache.activemq:apache-activemq` | Maven | From 6.0.0 | 6.2.4 |

Products: Apache Activemq, Apache Activemq Broker.

## How do I fix CVE-2026-39304?

Upgrade org.apache.activemq:activemq-all to a fixed version for your release line: 5.19.4 or 6.2.4.

## Is CVE-2026-39304 being exploited?

There is no known exploitation of CVE-2026-39304 in the wild and no public exploit code.

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39304 and fix it if it is affected.

What it is: CVE-2026-39304 is a high-severity denial of service vulnerability in Apache Activemq, published on 10 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39304 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.4
- org.apache.activemq:activemq-all (Maven): affected all versions; fixed in 5.19.4
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.4
- org.apache.activemq:activemq-all (Maven): affected from 6.0.0; fixed in 6.2.4
- activemq (Bitnami): affected all versions; fixed in 5.19.4, 6.2.4
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.4
- org.apache.activemq:activemq-broker (Maven): affected all versions; fixed in 5.19.4
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.4
- org.apache.activemq:activemq-broker (Maven): affected from 6.0.0; fixed in 6.2.4
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.19.4
- org.apache.activemq:activemq-client (Maven): affected all versions; fixed in 5.19.4
- org.apache.activemq:activemq-client (Maven): affected from 6.0.0; fixed in 6.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39304/ (Markdown: https://insights.sbomify.com/CVE-2026-39304/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39304
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39304
- OSV: https://osv.dev/vulnerability/CVE-2026-39304

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39304/
Summaries are generated and may contain mistakes; the official description above is the record.
