# CVE-2026-39308: PraisonAI recipe registry publish path traversal allows out-of-root file write

> A malicious publisher can write files outside the registry root via path traversal in the recipe publish endpoint, affecting PraisonAI deployments.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-r9x3-wx45-2v7f, PYSEC-2026-2922

## What is CVE-2026-39308?

CVE-2026-39308 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI is a multi-agent teams system. Prior to 1.5.113, PraisonAI's recipe registry publish endpoint writes uploaded recipe bundles to a filesystem path derived from the bundle's internal manifest.json before it verifies that the manifest name and version match the HTTP route. A malicious publisher can place ../ traversal sequences in the bundle manifest and cause the registry server to create files outside the configured registry root even though the request is ultimately rejected with HTTP 400. This is an arbitrary file write / path traversal issue on the registry host. It affects deployments that expose the recipe registry publish flow. If the registry is intentionally run without a token, any network client that can reach the service can trigger it. If a token is configured, any user with publish access can still exploit it. This vulnerability is fixed in 1.5.113.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-39308?

3 open source packages ship an affected version, including praisonai and PraisonAI. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai` | PyPI | All versions | 4.5.113 |
| `praisonai` | PyPI | All versions | 4.5.113 |
| `PraisonAI` | PyPI | All versions | 4.5.113 |

Products: Praison Praisonai.

## How do I fix CVE-2026-39308?

Upgrade praisonai to 4.5.113 or later.

## Is CVE-2026-39308 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39308 exists.

## Other vulnerabilities in MervinPraison PraisonAI

- [CVE-2026-39888](https://insights.sbomify.com/CVE-2026-39888/): PraisonAIAgents has a sandbox escape via exception frame traversal in `execute_code` (subprocess mode) (critical 10.0)
- [CVE-2026-41497](https://insights.sbomify.com/CVE-2026-41497/): Incomplete fix for CVE-2026-34935: Command Injection in MervinPraison/PraisonAI (critical 9.8)
- [CVE-2026-40288](https://insights.sbomify.com/CVE-2026-40288/): PraisonAI: Critical RCE via `type: job` workflow YAML (critical 9.8)
- [CVE-2026-39890](https://insights.sbomify.com/CVE-2026-39890/): PraisonAI Affected by Remote Code Execution via YAML Deserialization in Agent Definition Loading (critical 9.8)
- [CVE-2026-34934](https://insights.sbomify.com/CVE-2026-34934/): PraisonAI: Second-Order SQL Injection in `get_all_user_threads` (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39308 and fix it if it is affected.

What it is: CVE-2026-39308 is a high-severity path traversal vulnerability in MervinPraison PraisonAI, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39308 exists.

Affected packages and fixed versions:
- praisonai (PyPI): affected all versions; fixed in 4.5.113
- praisonai (PyPI): affected all versions; fixed in 4.5.113
- PraisonAI (PyPI): affected all versions; fixed in 4.5.113

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39308/ (Markdown: https://insights.sbomify.com/CVE-2026-39308/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39308
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39308
- OSV: https://osv.dev/vulnerability/CVE-2026-39308

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39308/
Summaries are generated and may contain mistakes; the official description above is the record.
