# CVE-2026-39313: MCP-Framework: Unbounded memory allocation in readRequestBody allows denial of service via HTTP transport

> Remote attackers can crash MCP servers by sending large HTTP requests due to unbounded memory allocation in the readRequestBody function.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Apr 2026
- **Updated:** 17 Apr 2026
- **Also known as:** GHSA-353c-v8x9-v7c3

## What is CVE-2026-39313?

CVE-2026-39313 is a high-severity denial of service vulnerability in QuantGeekDev mcp-framework, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mcp-framework is a framework for building Model Context Protocol (MCP) servers. In versions 0.2.21 and below, the readRequestBody() function in the HTTP transport concatenates request body chunks into a string with no size limit. Although a maxMessageSize configuration value exists, it is never enforced in readRequestBody(). A remote unauthenticated attacker can crash any mcp-framework HTTP server by sending a single large POST request to /mcp, causing memory exhaustion and denial of service. This issue has been fixed in version 0.2.22.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-39313?

2 open source packages ship an affected version, including mcp-framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mcp-framework` | npm | All versions | 0.2.22 |
| `mcp-framework` | npm | All versions | 0.2.22 |

## How do I fix CVE-2026-39313?

Upgrade mcp-framework to 0.2.22 or later.

## Is CVE-2026-39313 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39313 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39313 and fix it if it is affected.

What it is: CVE-2026-39313 is a high-severity denial of service vulnerability in QuantGeekDev mcp-framework, published on 16 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39313 exists.

Affected packages and fixed versions:
- mcp-framework (npm): affected all versions; fixed in 0.2.22
- mcp-framework (npm): affected all versions; fixed in 0.2.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39313/ (Markdown: https://insights.sbomify.com/CVE-2026-39313/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39313
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39313
- OSV: https://osv.dev/vulnerability/CVE-2026-39313

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39313/
Summaries are generated and may contain mistakes; the official description above is the record.
