# CVE-2026-39363: Vite Affected by Arbitrary File Read via Vite Dev Server WebSocket

> An attacker can read arbitrary files on the server by exploiting a missing access control check in the Vite dev server WebSocket interface.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-p9ff-h696-f583, MINI-f68f-xwf4-c44x, MINI-gjgf-fc8w-hmwj, MINI-hmgf-hq9g-mjm5, MINI-rf4p-vjh3-5j42, MINI-rgqg-prpf-jq9h, MINI-vmj5-x996-phm6, ROOT-APP-NPM-CVE-2026-39363

## What is CVE-2026-39363?

CVE-2026-39363 is a high-severity path traversal vulnerability in vitejs vite, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vite is a frontend tooling framework for JavaScript. From 6.0.0 to before 6.4.2, 7.3.2, and 8.0.5, if it is possible to connect to the Vite dev server’s WebSocket without an Origin header, an attacker can invoke fetchModule via the custom WebSocket event vite:invoke and combine file://... with ?raw (or ?inline) to retrieve the contents of arbitrary files on the server as a JavaScript string (e.g., export default "..."). The access control enforced in the HTTP request path (such as server.fs.allow) is not applied to this WebSocket-based execution path. This vulnerability is fixed in 6.4.2, 7.3.2, and 8.0.5.

Weakness: CWE-1220 (Insufficient Granularity of Access Control), CWE-306 (Missing Authentication for Critical Functionality), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-39363?

6 open source packages ship an affected version, including vite. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vite` | npm | From 6.0.0 | 6.4.2 |
| `vite` | npm | From 6.0.0 | 6.4.2 |
| `vite` | npm | From 7.0.0 | 7.3.2 |
| `vite` | npm | From 7.0.0 | 7.3.2 |
| `vite` | npm | From 8.0.0 | 8.0.5 |
| `vite` | npm | From 8.0.0 | 8.0.5 |

Products: Vitejs Vite, Voidzero Vite\+.

## How do I fix CVE-2026-39363?

Upgrade vite to a fixed version for your release line: 6.4.2, 7.3.2 or 8.0.5.

## Is CVE-2026-39363 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39363 exists.

Public exploit code:

- CVE-2026-39363 AI  analysis (github_poc): https://github.com/Firebasky/CVE-2026-39363
- CVE-2026-39363批量检测 (github_poc): https://github.com/f4s1on/CVE-2026-39363
- 方便实用的CVE-2026-39363利用工具 (github_poc): https://github.com/sunynov/CVE-2026-39363
- Vite Dev Server - Arbitrary File Read (nuclei)

## Other vulnerabilities in vitejs vite

- [CVE-2025-31125](https://insights.sbomify.com/CVE-2025-31125/): Vite Vitejs Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-53571](https://insights.sbomify.com/CVE-2026-53571/): Vite: `server.fs.deny` bypass on Windows alternate paths (high 8.2)
- [CVE-2026-39364](https://insights.sbomify.com/CVE-2026-39364/): Vite has a `server.fs.deny` bypass with queries (high 8.2)
- [CVE-2024-23331](https://insights.sbomify.com/CVE-2024-23331/): Vite dev server option `server.fs.deny` can be bypassed when hosted on case-insensitive filesystem (high 7.5)
- [CVE-2023-34092](https://insights.sbomify.com/CVE-2023-34092/): Vite Server Options (server.fs.deny) can be bypassed using double forward-slash (//) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39363 and fix it if it is affected.

What it is: CVE-2026-39363 is a high-severity path traversal vulnerability in vitejs vite, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39363 exists.

Affected packages and fixed versions:
- vite (npm): affected from 6.0.0; fixed in 6.4.2
- vite (npm): affected from 6.0.0; fixed in 6.4.2
- vite (npm): affected from 7.0.0; fixed in 7.3.2
- vite (npm): affected from 7.0.0; fixed in 7.3.2
- vite (npm): affected from 8.0.0; fixed in 8.0.5
- vite (npm): affected from 8.0.0; fixed in 8.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39363/ (Markdown: https://insights.sbomify.com/CVE-2026-39363/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39363
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39363
- OSV: https://osv.dev/vulnerability/CVE-2026-39363

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39363/
Summaries are generated and may contain mistakes; the official description above is the record.
