# CVE-2026-39364: Vite has a `server.fs.deny` bypass with queries

> Attackers can bypass file access restrictions on the Vite dev server to read sensitive files like .env by appending specific query parameters.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 17 Aug 2026
- **Also known as:** GHSA-v2wj-q39q-566r, MINI-2qv7-j87w-cgwp, MINI-73f9-544x-mpp9, MINI-wc8h-63mh-72mq, MINI-xx84-hrc9-j47r

## What is CVE-2026-39364?

CVE-2026-39364 is a high-severity vulnerability in vitejs vite, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vite is a frontend tooling framework for JavaScript. From 7.1.0 to before 7.3.2 and 8.0.5, on the Vite dev server, files that should be blocked by server.fs.deny (e.g., .env, *.crt) can be retrieved with HTTP 200 responses when query parameters such as ?raw, ?import&raw, or ?import&url&inline are appended. This vulnerability is fixed in 7.3.2 and 8.0.5.

Weakness: CWE-472 (External Control of Assumed-Immutable Web Parameter), CWE-284 (Improper Access Control), CWE-180 (Incorrect Behavior Order: Validate Before Canonicalize)

## Which versions are affected by CVE-2026-39364?

4 open source packages ship an affected version, including vite. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vite` | npm | From 7.1.0 | 7.3.2 |
| `vite` | npm | From 7.1.0 | 7.3.2 |
| `vite` | npm | From 8.0.0 | 8.0.5 |
| `vite` | npm | From 8.0.0 | 8.0.5 |

Products: Vitejs Vite, Voidzero Vite\+.

## How do I fix CVE-2026-39364?

Upgrade vite to a fixed version for your release line: 7.3.2 or 8.0.5.

## Is CVE-2026-39364 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39364 exists.

Public exploit code:

- Vite Dev Server - Directory Traversal (nuclei): http/cves/2026/CVE-2026-39364.yaml

## Other vulnerabilities in vitejs vite

- [CVE-2025-31125](https://insights.sbomify.com/CVE-2025-31125/): Vite Vitejs Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-53571](https://insights.sbomify.com/CVE-2026-53571/): Vite: `server.fs.deny` bypass on Windows alternate paths (high 8.2)
- [CVE-2026-39363](https://insights.sbomify.com/CVE-2026-39363/): Vite Affected by Arbitrary File Read via Vite Dev Server WebSocket (high 8.2)
- [CVE-2024-23331](https://insights.sbomify.com/CVE-2024-23331/): Vite dev server option `server.fs.deny` can be bypassed when hosted on case-insensitive filesystem (high 7.5)
- [CVE-2023-34092](https://insights.sbomify.com/CVE-2023-34092/): Vite Server Options (server.fs.deny) can be bypassed using double forward-slash (//) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39364 and fix it if it is affected.

What it is: CVE-2026-39364 is a high-severity vulnerability in vitejs vite, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39364 exists.

Affected packages and fixed versions:
- vite (npm): affected from 7.1.0; fixed in 7.3.2
- vite (npm): affected from 7.1.0; fixed in 7.3.2
- vite (npm): affected from 8.0.0; fixed in 8.0.5
- vite (npm): affected from 8.0.0; fixed in 8.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39364/ (Markdown: https://insights.sbomify.com/CVE-2026-39364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39364
- OSV: https://osv.dev/vulnerability/CVE-2026-39364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39364/
Summaries are generated and may contain mistakes; the official description above is the record.
