# CVE-2026-39365: Vite has a Path Traversal in Optimized Deps `.map` Handling

> Attackers can bypass file access restrictions to read source map files outside the project root via crafted requests to the Vite dev server.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** CLSA-2026-1778201087, GHSA-4w7w-66w2-5vf9, MINI-3p7r-v996-8f8p, MINI-7x4h-6rf7-9689, MINI-f5qh-qpm4-xx7f, MINI-g95j-3hj7-663j, MINI-j4mj-q69p-8pv8, MINI-rmwh-xwgm-423r, MINI-vppf-7x6q-hx39, ROOT-APP-NPM-CVE-2026-39365

## What is CVE-2026-39365?

CVE-2026-39365 is a medium-severity path traversal vulnerability in vitejs vite, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vite is a frontend tooling framework for JavaScript. From 6.0.0 to before 6.4.2, 7.3.2, and 8.0.5, the dev server’s handling of .map requests for optimized dependencies resolves file paths and calls readFile without restricting ../ segments in the URL. As a result, it is possible to bypass the server.fs.strict allow list and retrieve .map files located outside the project root, provided they can be parsed as valid source map JSON. This vulnerability is fixed in 6.4.2, 7.3.2, and 8.0.5.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-39365?

6 open source packages ship an affected version, including vite. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vite` | npm | All versions | 6.4.2 |
| `vite` | npm | All versions | 6.4.2 |
| `vite` | npm | From 7.0.0 | 7.3.2 |
| `vite` | npm | From 7.0.0 | 7.3.2 |
| `vite` | npm | From 8.0.0 | 8.0.5 |
| `vite` | npm | From 8.0.0 | 8.0.5 |

Products: Vitejs Vite, Voidzero Vite\+.

## How do I fix CVE-2026-39365?

Upgrade vite to a fixed version for your release line: 6.4.2, 7.3.2 or 8.0.5.

## Is CVE-2026-39365 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39365 exists.

Public exploit code:

- Vite Dev Server - Path Traversal in Optimized Deps .map Handling (nuclei): http/cves/2026/CVE-2026-39365.yaml

## Other vulnerabilities in vitejs vite

- [CVE-2025-31125](https://insights.sbomify.com/CVE-2025-31125/): Vite Vitejs Improper Access Control (medium 5.3, exploited in the wild)
- [CVE-2026-53571](https://insights.sbomify.com/CVE-2026-53571/): Vite: `server.fs.deny` bypass on Windows alternate paths (high 8.2)
- [CVE-2026-39363](https://insights.sbomify.com/CVE-2026-39363/): Vite Affected by Arbitrary File Read via Vite Dev Server WebSocket (high 8.2)
- [CVE-2026-39364](https://insights.sbomify.com/CVE-2026-39364/): Vite has a `server.fs.deny` bypass with queries (high 8.2)
- [CVE-2024-23331](https://insights.sbomify.com/CVE-2024-23331/): Vite dev server option `server.fs.deny` can be bypassed when hosted on case-insensitive filesystem (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39365 and fix it if it is affected.

What it is: CVE-2026-39365 is a medium-severity path traversal vulnerability in vitejs vite, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39365 exists.

Affected packages and fixed versions:
- vite (npm): affected all versions; fixed in 6.4.2
- vite (npm): affected all versions; fixed in 6.4.2
- vite (npm): affected from 7.0.0; fixed in 7.3.2
- vite (npm): affected from 7.0.0; fixed in 7.3.2
- vite (npm): affected from 8.0.0; fixed in 8.0.5
- vite (npm): affected from 8.0.0; fixed in 8.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39365/ (Markdown: https://insights.sbomify.com/CVE-2026-39365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39365
- OSV: https://osv.dev/vulnerability/CVE-2026-39365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39365/
Summaries are generated and may contain mistakes; the official description above is the record.
