CVE-2026-39373 JWCrypto: JWE ZIP decompression bomb
An unauthenticated attacker can cause memory exhaustion and denial of service by sending crafted JWE tokens with ZIP compression.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-39373?
CVE-2026-39373 is a medium-severity denial of service vulnerability in latchset jwcrypto, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
JWCrypto implements JWK, JWS, and JWE specifications using python-cryptography. Prior to 1.5.7, an unauthenticated attacker can exhaust server memory by sending crafted JWE tokens with ZIP compression. The existing patch for CVE-2024-28102 limits input token size to 250KB but does not validate the decompressed output size. An unauthenticated attacker can cause memory exhaustion on memory-constrained systems. A token under the 250KB input limit can decompress to approximately 100MB. This vulnerability is fixed in 1.5.7.
Weakness: CWE-409
Which versions are affected by CVE-2026-39373?
3 open source packages ship an affected version, including jwcrypto. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
jwcrypto PyPI | All versions | 1.5.7 |
jwcrypto PyPI | All versions | 1.5.7 |
jwcrypto PyPI | All versions | 1.5.7 |
Linux distribution packages (9)
python3-jwcrypto AlmaLinux:10 | All versions | 1.5.6-5.el10_2 |
python3-jwcrypto AlmaLinux:9 | All versions | 1.5.6-3.el9_8 |
python-jwcrypto Red Hat:enterprise_linux:10.2 | All versions | 0:1.5.6-5.el10_2 |
python3-jwcrypto Red Hat:enterprise_linux:10.2 | All versions | 0:1.5.6-5.el10_2 |
python-jwcrypto Red Hat:enterprise_linux:9::appstream | All versions | 0:1.5.6-3.el9_8 |
python3-jwcrypto Red Hat:enterprise_linux:9::appstream | All versions | 0:1.5.6-3.el9_8 |
python-jwcrypto Rocky Linux:10 | All versions | 0:1.5.6-5.el10_2 |
python-jwcrypto Rocky Linux:9 | All versions | 0:1.5.6-3.el9_8 |
python-jwcrypto openSUSE:Tumbleweed | All versions | 1.5.7-2.1 |
Products include Latchset Jwcrypto.
How do I fix CVE-2026-39373?
Upgrade jwcrypto to 1.5.7 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-39373 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39373 exists.
Other vulnerabilities in latchset jwcrypto
Sources
Also known as ALSA-2026:19042, ALSA-2026:19197, AZL-82055, DEBIAN-CVE-2026-39373, GHSA-fjrm-76x2-c4q4, OESA-2026-1923 and 13 more.