# CVE-2026-39373: JWCrypto: JWE ZIP decompression bomb

> An unauthenticated attacker can cause memory exhaustion and denial of service by sending crafted JWE tokens with ZIP compression.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** ALSA-2026:19042, ALSA-2026:19197, AZL-82055, DEBIAN-CVE-2026-39373, GHSA-fjrm-76x2-c4q4, OESA-2026-1923, OESA-2026-1924, OESA-2026-1925, OESA-2026-1926, OESA-2026-3636, PYSEC-2026-70, RHSA-2026:19042, RHSA-2026:19197, RLSA-2026:19042, RLSA-2026:19197, SUSE-SU-2026:21425-1, UBUNTU-CVE-2026-39373, openSUSE-SU-2026:10576-1, openSUSE-SU-2026:20644-1

## What is CVE-2026-39373?

CVE-2026-39373 is a medium-severity denial of service vulnerability in latchset jwcrypto, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

JWCrypto implements JWK, JWS, and JWE specifications using python-cryptography. Prior to 1.5.7, an unauthenticated attacker can exhaust server memory by sending crafted JWE tokens with ZIP compression. The existing patch for CVE-2024-28102  limits input token size to 250KB but does not validate the decompressed output size. An unauthenticated attacker can cause memory exhaustion on memory-constrained systems. A token under the 250KB input limit can decompress to approximately 100MB. This vulnerability is fixed in 1.5.7.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-39373?

3 open source packages ship an affected version, including jwcrypto. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jwcrypto` | PyPI | All versions | 1.5.7 |
| `jwcrypto` | PyPI | All versions | 1.5.7 |
| `jwcrypto` | PyPI | All versions | 1.5.7 |
| `python3-jwcrypto` | AlmaLinux:10 | All versions | 1.5.6-5.el10_2 |
| `python3-jwcrypto` | AlmaLinux:9 | All versions | 1.5.6-3.el9_8 |
| `python-jwcrypto` | Red Hat:enterprise_linux:10.2 | All versions | 0:1.5.6-5.el10_2 |
| `python3-jwcrypto` | Red Hat:enterprise_linux:10.2 | All versions | 0:1.5.6-5.el10_2 |
| `python-jwcrypto` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.5.6-3.el9_8 |
| `python3-jwcrypto` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.5.6-3.el9_8 |
| `python-jwcrypto` | Rocky Linux:10 | All versions | 0:1.5.6-5.el10_2 |
| `python-jwcrypto` | Rocky Linux:9 | All versions | 0:1.5.6-3.el9_8 |
| `python-jwcrypto` | openSUSE:Tumbleweed | All versions | 1.5.7-2.1 |

Products: Latchset Jwcrypto.

## How do I fix CVE-2026-39373?

Upgrade jwcrypto to 1.5.7 or later.

## Is CVE-2026-39373 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39373 exists.

## Other vulnerabilities in latchset jwcrypto

- [CVE-2016-6298](https://insights.sbomify.com/CVE-2016-6298/): jwcrypto lacks the Random Filling protection mechanism (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39373 and fix it if it is affected.

What it is: CVE-2026-39373 is a medium-severity denial of service vulnerability in latchset jwcrypto, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39373 exists.

Affected packages and fixed versions:
- jwcrypto (PyPI): affected all versions; fixed in 1.5.7
- jwcrypto (PyPI): affected all versions; fixed in 1.5.7
- jwcrypto (PyPI): affected all versions; fixed in 1.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39373/ (Markdown: https://insights.sbomify.com/CVE-2026-39373/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39373
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39373
- OSV: https://osv.dev/vulnerability/CVE-2026-39373

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39373/
Summaries are generated and may contain mistakes; the official description above is the record.
