{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39380 exists.","fix":"No fix has been published for CVE-2026-39380 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-39380 is a medium-severity cross-site scripting vulnerability in opensourcepos, published on 7 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-39380 and fix it if it is affected.\n\nWhat it is: CVE-2026-39380 is a medium-severity cross-site scripting vulnerability in opensourcepos, published on 7 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39380 exists.\n\nAffected product: opensourcepos. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-39380/ (Markdown: https://insights.sbomify.com/CVE-2026-39380/index.md)","id":"CVE-2026-39380","markdown":"https://insights.sbomify.com/CVE-2026-39380/index.md","name":"CVE-2026-39380","record":{"aliases":["GHSA-7hg5-68rx-xpmg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Point of Sale application","requires_auth":"low_privilege","summary":"Attackers can inject malicious JavaScript via the stock location configuration, leading to code execution in the employee interface.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"open_source_point_of_sale","vendor":"opensourcepos"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Open Source Point of Sale is a web based point-of-sale application written in PHP using CodeIgniter framework. Prior to 3.4.3, a Stored Cross-Site Scripting (XSS) vulnerability exists in the Stock Locations configuration feature. The application fails to properly sanitize user input supplied through the stock_location parameter, allowing attackers to inject malicious JavaScript code that is stored in the database and executed when rendered in the Employees interface. This vulnerability is fixed in 3.4.3.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Open Source Point of Sale has Stored XSS in Stock Location (Configuration)","id":"CVE-2026-39380","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2026"},"n_packages":0,"n_references":1,"next":{"headline":"Parse Server's Endpoint `/sessions/me` bypasses `_Session` `protectedFields`","id":"CVE-2026-39381"},"packages":[],"prev":{"headline":"nbconvert has an Arbitrary File Read via Path Traversal in HTMLExporter Image Embedding","id":"CVE-2026-39378"},"products":["opensourcepos"],"published":"2026-04-07","related":[{"cvss_score":8.8,"headline":"Open Source Point of Sale is Vulnerable to SQL Injection Through its Item Search Functionality","id":"CVE-2026-32888","kev_date_added":null,"published":"2026-03-20"},{"cvss_score":8.8,"headline":"Path traversal in n/a","id":"CVE-2026-26746","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":8.8,"headline":"opensourcepos has Cross-Site Request Forgery vulnerability that leads to Unauthorized Administrator Creation","id":"CVE-2025-68434","kev_date_added":null,"published":"2025-12-17"},{"cvss_score":8.1,"headline":"opensourcepos has a Cross-site Scripting vulnerability","id":"CVE-2025-68147","kev_date_added":null,"published":"2025-12-17"},{"cvss_score":7.5,"headline":"Auth bypass in n/a","id":"CVE-2025-63800","kev_date_added":null,"published":"2025-11-18"},{"cvss_score":7.4,"headline":"Command injection in n/a","id":"CVE-2025-70093","kev_date_added":null,"published":"2026-02-13"},{"cvss_score":7.2,"headline":"Cross-site scripting in n/a","id":"CVE-2025-66921","kev_date_added":null,"published":"2025-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["opensourcepos"]},"summary":"Attackers can inject malicious JavaScript via the stock location configuration, leading to code execution in the employee interface.","url":"https://insights.sbomify.com/CVE-2026-39380/"}