# CVE-2026-39385: Frappe LMS enrollment bypass in paid courses via unrelated batch

> Attackers can bypass payment validation for paid courses by enrolling via unrelated batches, allowing unauthorized access to premium content.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 20 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-c4xh-2rcm-6mgc

## What is CVE-2026-39385?

CVE-2026-39385 is a high-severity vulnerability in frappe lms, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Frappe LMS is an open source learning management system. In version 2.51.0 and earlier, a user could bypass payment validation for courses by using unrelated batch. This has been patched in 2.52.0 with enrollment now validating that the batch is linked to course.

Weakness: CWE-288 (Authentication Bypass Using an Alternate Path or Channel)

## Which versions are affected by CVE-2026-39385?


## How do I fix CVE-2026-39385?

No fix has been published for CVE-2026-39385 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-39385 being exploited?

There is no known exploitation of CVE-2026-39385 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39385 and fix it if it is affected.

What it is: CVE-2026-39385 is a high-severity vulnerability in frappe lms, published on 20 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39385 in the wild and no public exploit code.

Affected product: frappe lms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39385/ (Markdown: https://insights.sbomify.com/CVE-2026-39385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39385
- OSV: https://osv.dev/vulnerability/CVE-2026-39385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39385/
Summaries are generated and may contain mistakes; the official description above is the record.
