# CVE-2026-39386: Neko has Self-service Privilege Escalation for Authenticated Users

> Authenticated users can escalate to full administrative control of the Neko virtual browser instance, compromising the entire system.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** GHSA-2gw9-c2r2-f5qf, GO-2026-4960

## What is CVE-2026-39386?

CVE-2026-39386 is a high-severity vulnerability in m1k1o neko, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Neko is a a self-hosted virtual browser that runs in Docker and uses WebRTC In versions 3.0.0 through 3.0.10 and 3.1.0 through 3.1.1, any authenticated user can immediately obtain full administrative control of the entire Neko instance (member management, room settings, broadcast control, session termination, etc.). This results in a complete compromise of the instance. The vulnerability has been patched in v3.0.11 and v3.1.2. If upgrading is not immediately possible, the following mitigations can reduce risk: Restrict access to trusted users only (avoid granting accounts to untrusted parties); ensure all user passwords are strong and only shared with trusted individuals; run the instance only when needed; avoid leaving it continuously exposed; place the instance behind authentication layers such as a reverse proxy with additional access controls; disable or restrict access to the /api/profile endpoint if feasible; and/or monitor for suspicious privilege changes or unexpected administrative actions. Note that these are temporary mitigations and do not fully eliminate the vulnerability. Upgrading is strongly recommended.

Weakness: CWE-862 (Missing Authorization), CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-269 (Improper Privilege Management), CWE-284 (Improper Access Control), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-39386?

5 open source packages ship an affected version, including github.com/m1k1o/neko/server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/m1k1o/neko/server` | Go | From 0.0.0-20250322225643-212bf8a60756 | 0.0.0-20260406184107-c54bcf1ee211 |
| `github.com/m1k1o/neko/server` | Go | From 0.0.0-20250322225643-212bf8a60756 | 0.0.0-20260406184107-c54bcf1ee211 |
| `github.com/m1k1o/neko/server` | Go | From 0.0.0-20250326225119-51bbad7650d3 | 0.0.0-20260406184107-c54bcf1ee211 |
| `github.com/m1k1o/neko/server` | Go | From 3.0.0 | 3.0.11 |
| `github.com/m1k1o/neko/server` | Go | From 3.0.0 | 3.0.11 |

Products: M1k1o Neko.

## How do I fix CVE-2026-39386?

Upgrade github.com/m1k1o/neko/server to a fixed version for your release line: 0.0.0-20260406184107-c54bcf1ee211 or 3.0.11.

## Is CVE-2026-39386 being exploited?

There is no known exploitation of CVE-2026-39386 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39386 and fix it if it is affected.

What it is: CVE-2026-39386 is a high-severity vulnerability in m1k1o neko, published on 21 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39386 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/m1k1o/neko/server (Go): affected from 0.0.0-20250322225643-212bf8a60756; fixed in 0.0.0-20260406184107-c54bcf1ee211
- github.com/m1k1o/neko/server (Go): affected from 0.0.0-20250322225643-212bf8a60756; fixed in 0.0.0-20260406184107-c54bcf1ee211
- github.com/m1k1o/neko/server (Go): affected from 0.0.0-20250326225119-51bbad7650d3; fixed in 0.0.0-20260406184107-c54bcf1ee211
- github.com/m1k1o/neko/server (Go): affected from 3.0.0; fixed in 3.0.11
- github.com/m1k1o/neko/server (Go): affected from 3.0.0; fixed in 3.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39386/ (Markdown: https://insights.sbomify.com/CVE-2026-39386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39386
- OSV: https://osv.dev/vulnerability/CVE-2026-39386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39386/
Summaries are generated and may contain mistakes; the official description above is the record.
