# CVE-2026-39387: BoidCMS: Local File Inclusion (LFI) leads to Remote Code Execution (RCE) via tpl parameter

> An authenticated administrator can exploit a path traversal vulnerability in the tpl parameter to include arbitrary files, leading to remote code execution.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Apr 2026
- **Updated:** 15 Apr 2026
- **Also known as:** GHSA-45xp-xw54-6cv6

## What is CVE-2026-39387?

CVE-2026-39387 is a high-severity path traversal vulnerability in BoidCMS, published on 14 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

BoidCMS is an open-source, PHP-based flat-file CMS for building simple websites and blogs, using JSON as its database. Versions prior to 2.1.3 are vulnerable to a critical Local File Inclusion (LFI) attack via the tpl parameter, which can lead to Remote Code Execution (RCE).The application fails to sanitize the tpl (template) parameter during page creation and updates. This parameter is passed directly to a require_once() statement without path validation. An authenticated administrator can exploit this by injecting path traversal sequences (../) into the tpl value to escape the intended theme directory and include arbitrary files — specifically, files from the server's media/ directory. When combined with the file upload functionality, this becomes a full RCE chain: an attacker can first upload a file with embedded PHP code (e.g., disguised as image data), then use the path traversal vulnerability to include that file via require_once(), executing the embedded code with web server privileges. This issue has been fixed in version 2.1.3.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program)

## Which versions are affected by CVE-2026-39387?

It affects 1 product.


Products: Boidcms Boidcms.

## How do I fix CVE-2026-39387?

No fix has been published for CVE-2026-39387 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-39387 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39387 exists.

Public exploit code:

- BoidCMS <= 2.1.2 RCE Exploit (github_poc): https://github.com/xp1tr/CVE-2026-39387

## Other vulnerabilities in BoidCMS

- [CVE-2023-38836](https://insights.sbomify.com/CVE-2023-38836/): File upload in n/a (high 8.8)
- [CVE-2024-32342](https://insights.sbomify.com/CVE-2024-32342/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2024-32343](https://insights.sbomify.com/CVE-2024-32343/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2023-48824](https://insights.sbomify.com/CVE-2023-48824/): Cross-site scripting in n/a (medium 5.4)
- [CVE-2024-53255](https://insights.sbomify.com/CVE-2024-53255/): Reflected Cross-site Scripting in /admin?page=media via file Parameter in BoidCMS (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39387 and fix it if it is affected.

What it is: CVE-2026-39387 is a high-severity path traversal vulnerability in BoidCMS, published on 14 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39387 exists.

Affected product: BoidCMS. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39387/ (Markdown: https://insights.sbomify.com/CVE-2026-39387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39387
- OSV: https://osv.dev/vulnerability/CVE-2026-39387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39387/
Summaries are generated and may contain mistakes; the official description above is the record.
