# CVE-2026-39388: OpenBao's Certificate Authentication Allows Token Renewal With Different Certificate

> Attackers with sibling certificates can renew tokens for different roles, extending lease lifetimes and bypassing certificate binding restrictions.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** BIT-openbao-2026-39388, GHSA-7ccv-rp6m-rffr, GO-2026-5213

## What is CVE-2026-39388?

CVE-2026-39388 is a low-severity authentication bypass vulnerability in openbao, published on 21 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to version 2.5.3, OpenBao's Certificate authentication method, when a token renewal is requested and `disable_binding=true` is set, attempts to verify the current request's presented mTLS certificate matches the original. Token renewals for other authentication methods do not require any supplied login information. Due to incorrect matching, the certificate authentication method would allow renewal of tokens for which the attacker had a sibling certificate+key signed by the same CA, but which did not necessarily match the original role or the originally supplied certificate. This implies an attacker could still authenticate to OpenBao in a similar scope, however, token renewal implies that an attacker may be able to extend the lifetime of dynamic leases held by the original token. This attack requires knowledge of either the original token or its accessor. This vulnerability is original from HashiCorp Vault. This is addressed in v2.5.3. As a workaround, ensure privileged roles are tightly scoped to single certificates.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-39388?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420160924-abe84e1af4c3 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420160924-abe84e1af4c3 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420160924-abe84e1af4c3 |
| `openbao` | Bitnami | All versions | 2.5.3 |

Products: Openbao Openbao.

## How do I fix CVE-2026-39388?

Upgrade github.com/openbao/openbao to 0.0.0-20260420160924-abe84e1af4c3 or later.

## Is CVE-2026-39388 being exploited?

There is no known exploitation of CVE-2026-39388 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39388 and fix it if it is affected.

What it is: CVE-2026-39388 is a low-severity authentication bypass vulnerability in openbao, published on 21 Apr 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-39388 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420160924-abe84e1af4c3
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420160924-abe84e1af4c3
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420160924-abe84e1af4c3
- openbao (Bitnami): affected all versions; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39388/ (Markdown: https://insights.sbomify.com/CVE-2026-39388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39388
- OSV: https://osv.dev/vulnerability/CVE-2026-39388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39388/
Summaries are generated and may contain mistakes; the official description above is the record.
