CVE-2026-39395 Cosign's verify-blob-attestation reports false positive when payload parsing fails
Cosign incorrectly reports successful verification for malformed attestations, allowing attackers to bypass signature validation checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-39395?
CVE-2026-39395 is a medium-severity vulnerability in sigstore cosign, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cosign provides code signing and transparency for containers and binaries. Prior to 3.0.6 and 2.6.3, cosign verify-blob-attestation may erroneously report a "Verified OK" result for attestations with malformed payloads or mismatched predicate types. For old-format bundles and detached signatures, this was due to a logic flaw in the error handling of the predicate type validation. For new-format bundles, the predicate type validation was bypassed completely. This vulnerability is fixed in 3.0.6 and 2.6.3.
Weakness: CWE-754
Which versions are affected by CVE-2026-39395?
8 open source packages ship an affected version, including github.com/sigstore/cosign, cosign and github.com/sigstore/cosign/v2. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/sigstore/cosign Go | All versions | None |
github.com/sigstore/cosign Go | All versions | 2.6.3 |
github.com/sigstore/cosign Go | All versions | 2.6.3 |
github.com/sigstore/cosign Go | From 3.0.0 | 3.0.6 |
github.com/sigstore/cosign Go | From 3.0.0 | 3.0.6 |
cosign Bitnami | All versions | 2.6.3, 3.0.6 |
2 more packages
github.com/sigstore/cosign/v2 Go | All versions | 2.6.3 |
github.com/sigstore/cosign/v3 Go | From 3.0.0 | 3.0.6 |
Linux distribution packages (5)
cosign SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 3.0.6-150400.3.42.1 |
cosign SUSE:Linux Enterprise Server 16.0 | All versions | 3.0.6-160000.1.1 |
cosign SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 3.0.6-160000.1.1 |
cosign openSUSE:Leap 16.0 | All versions | 3.0.6-160000.1.1 |
cosign openSUSE:Tumbleweed | All versions | 3.0.6-1.1 |
Products include Sigstore Cosign.
How do I fix CVE-2026-39395?
Upgrade github.com/sigstore/cosign to a fixed version for your release line: 2.6.3 or 3.0.6.
Is CVE-2026-39395 being exploited?
There is no known exploitation of CVE-2026-39395 in the wild and no public exploit code.
Other vulnerabilities in sigstore cosign
- CVE-2022-35929 False positive signature verification in cosign
- CVE-2026-22703 Cosign verification accepts any valid Rekor entry under certain conditions
- CVE-2022-36056 Vulnerabilities with blob verification in sigstore cosign
- CVE-2024-29902 Cosign vulnerable to system-wide denial of service via malicious attachments
- CVE-2024-29903 Cosign vulnerable to machine-wide denial of service via malicious artifacts
Sources
Also known as BIT-cosign-2026-39395, CLEANSTART-2026-UN61335, CLEANSTART-2026-WB69722, DEBIAN-CVE-2026-39395, ECHO-da76-7fca-1d02, GHSA-w6c6-c85g-mmv6 and 39 more.