# CVE-2026-39395: Cosign's verify-blob-attestation reports false positive when payload parsing fails

> Cosign incorrectly reports successful verification for malformed attestations, allowing attackers to bypass signature validation checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** BIT-cosign-2026-39395, CLEANSTART-2026-UN61335, CLEANSTART-2026-WB69722, DEBIAN-CVE-2026-39395, ECHO-da76-7fca-1d02, GHSA-w6c6-c85g-mmv6, GO-2026-5694, MINI-2253-9f8h-8gp4, MINI-27xx-2hh5-wrv3, MINI-347c-cfh5-2q4w, MINI-36r3-jwmq-9cj2, MINI-44q7-m7q4-3qmx, MINI-4mf5-hpxj-h6qg, MINI-586q-79gw-w2h4, MINI-62cr-883c-rpv8, MINI-6hvx-h6ch-3ggc, MINI-6qgw-vhfq-657c, MINI-88wm-pmmv-c3px, MINI-8php-c9pq-j7f9, MINI-8v9c-j58x-3xhw, MINI-9c66-vjjw-qwwj, MINI-9wxj-6358-4f99, MINI-f26x-mqc7-m5x3, MINI-fpxp-hmr4-93vm, MINI-frx2-f57j-g77q, MINI-gm7r-5g9j-rc6g, MINI-h5mr-wjrg-4r6q, MINI-hc36-hq64-38fh, MINI-hg9f-jfm9-5w6j, MINI-jjh8-vx29-pgpp, MINI-jxwh-6774-g7h9, MINI-m3f6-j4fp-jcxv, MINI-m7q2-qhvq-48pr, MINI-mwwf-6hxm-gpxw, MINI-r24m-38q5-87gr, MINI-r2c6-9mhj-cvqc, MINI-r763-235m-xjv4, MINI-vvp7-h7cr-w2cj, MINI-vxcg-rv4m-4375, MINI-w8vc-w2f9-c779, SUSE-SU-2026:22344-1, SUSE-SU-2026:2365-1, UBUNTU-CVE-2026-39395, openSUSE-SU-2026:10753-1, openSUSE-SU-2026:21036-1

## What is CVE-2026-39395?

CVE-2026-39395 is a medium-severity vulnerability in sigstore cosign, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cosign provides code signing and transparency for containers and binaries. Prior to 3.0.6 and 2.6.3, cosign verify-blob-attestation may erroneously report a "Verified OK" result for attestations with malformed payloads or mismatched predicate types. For old-format bundles and detached signatures, this was due to a logic flaw in the error handling of the predicate type validation. For new-format bundles, the predicate type validation was bypassed completely. This vulnerability is fixed in 3.0.6 and 2.6.3.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2026-39395?

8 open source packages ship an affected version, including github.com/sigstore/cosign, cosign and github.com/sigstore/cosign/v2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sigstore/cosign` | Go | All versions | None |
| `github.com/sigstore/cosign` | Go | All versions | 2.6.3 |
| `github.com/sigstore/cosign` | Go | All versions | 2.6.3 |
| `github.com/sigstore/cosign` | Go | From 3.0.0 | 3.0.6 |
| `github.com/sigstore/cosign` | Go | From 3.0.0 | 3.0.6 |
| `cosign` | Bitnami | All versions | 2.6.3, 3.0.6 |
| `github.com/sigstore/cosign/v2` | Go | All versions | 2.6.3 |
| `github.com/sigstore/cosign/v3` | Go | From 3.0.0 | 3.0.6 |
| `cosign` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 3.0.6-150400.3.42.1 |
| `cosign` | SUSE:Linux Enterprise Server 16.0 | All versions | 3.0.6-160000.1.1 |
| `cosign` | SUSE:Linux Enterprise Server for SAP applications 16.0 | All versions | 3.0.6-160000.1.1 |
| `cosign` | openSUSE:Leap 16.0 | All versions | 3.0.6-160000.1.1 |
| `cosign` | openSUSE:Tumbleweed | All versions | 3.0.6-1.1 |

Products: Sigstore Cosign.

## How do I fix CVE-2026-39395?

Upgrade github.com/sigstore/cosign to a fixed version for your release line: 2.6.3 or 3.0.6.

## Is CVE-2026-39395 being exploited?

There is no known exploitation of CVE-2026-39395 in the wild and no public exploit code.

## Other vulnerabilities in sigstore cosign

- [CVE-2022-35929](https://insights.sbomify.com/CVE-2022-35929/): False positive signature verification in cosign (high 7.1)
- [CVE-2026-22703](https://insights.sbomify.com/CVE-2026-22703/): Cosign verification accepts any valid Rekor entry under certain conditions (medium 5.5)
- [CVE-2022-36056](https://insights.sbomify.com/CVE-2022-36056/): Vulnerabilities with blob verification in sigstore cosign (medium 5.5)
- [CVE-2024-29902](https://insights.sbomify.com/CVE-2024-29902/): Cosign vulnerable to system-wide denial of service via malicious attachments (medium 4.2)
- [CVE-2024-29903](https://insights.sbomify.com/CVE-2024-29903/): Cosign vulnerable to machine-wide denial of service via malicious artifacts (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39395 and fix it if it is affected.

What it is: CVE-2026-39395 is a medium-severity vulnerability in sigstore cosign, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-39395 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sigstore/cosign (Go): affected all versions; no fix listed
- github.com/sigstore/cosign (Go): affected all versions; fixed in 2.6.3
- github.com/sigstore/cosign (Go): affected all versions; fixed in 2.6.3
- github.com/sigstore/cosign (Go): affected from 3.0.0; fixed in 3.0.6
- github.com/sigstore/cosign (Go): affected from 3.0.0; fixed in 3.0.6
- cosign (Bitnami): affected all versions; fixed in 2.6.3, 3.0.6
- github.com/sigstore/cosign/v2 (Go): affected all versions; fixed in 2.6.3
- github.com/sigstore/cosign/v3 (Go): affected from 3.0.0; fixed in 3.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39395/ (Markdown: https://insights.sbomify.com/CVE-2026-39395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39395
- OSV: https://osv.dev/vulnerability/CVE-2026-39395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39395/
Summaries are generated and may contain mistakes; the official description above is the record.
