# CVE-2026-39396: OpenBao has Decompression Bomb via Unbounded Copy in OCI Plugin Extraction (DoS)

> An attacker can cause disk exhaustion and denial of service by serving a crafted OCI image with a decompression bomb to OpenBao's plugin extractor.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Apr 2026
- **Updated:** 21 Apr 2026
- **Also known as:** BIT-openbao-2026-39396, GHSA-r65v-xgwc-g56j, GO-2026-5609

## What is CVE-2026-39396?

CVE-2026-39396 is a low-severity denial of service vulnerability in openbao, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to version 2.5.3, `ExtractPluginFromImage()` in OpenBao's OCI plugin downloader extracts a plugin binary from a container image by streaming decompressed tar data via `io.Copy` with no upper bound on the number of bytes written. An attacker who controls or compromises the OCI registry referenced in the victim's configuration can serve a crafted image containing a decompression bomb that decompresses to an arbitrarily large file. The SHA256 integrity check occurs after the full file is written to disk, meaning the hash mismatch is detected only after the damage (disk exhaustion) has already occurred. This allow the attacker to replace **legit plugin image** with no need to change its signature. Version 2.5.3 contains a patch.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-674 (Uncontrolled Recursion), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-39396?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420180337-2b2a901aa9f7 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420180337-2b2a901aa9f7 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260420180337-2b2a901aa9f7 |
| `openbao` | Bitnami | All versions | 2.5.3 |

Products: Openbao Openbao.

## How do I fix CVE-2026-39396?

Upgrade github.com/openbao/openbao to 0.0.0-20260420180337-2b2a901aa9f7 or later.

## Is CVE-2026-39396 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39396 exists.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39396 and fix it if it is affected.

What it is: CVE-2026-39396 is a low-severity denial of service vulnerability in openbao, published on 21 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39396 exists.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420180337-2b2a901aa9f7
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420180337-2b2a901aa9f7
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260420180337-2b2a901aa9f7
- openbao (Bitnami): affected all versions; fixed in 2.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39396/ (Markdown: https://insights.sbomify.com/CVE-2026-39396/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39396
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39396
- OSV: https://osv.dev/vulnerability/CVE-2026-39396

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39396/
Summaries are generated and may contain mistakes; the official description above is the record.
