# CVE-2026-39397: @delmaredigital/payload-puc is missing authorization on /api/puck/* CRUD endpoints allows unauthenticated access to Puck-registered collections

> Unauthenticated attackers can access and modify Puck-registered collections via API endpoints due to missing authorization checks in the PayloadCMS plugin.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-65w6-pf7x-5g85

## What is CVE-2026-39397?

CVE-2026-39397 is a critical missing authorization vulnerability in delmaredigital payload-puck, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@delmaredigital/payload-puck is a PayloadCMS plugin for integrating Puck visual page builder. Prior to 0.6.23, all /api/puck/* CRUD endpoint handlers registered by createPuckPlugin() called Payload's local API with the default overrideAccess: true, bypassing all collection-level access control. The access option passed to createPuckPlugin() and any access rules defined on Puck-registered collections were silently ignored on these endpoints. This vulnerability is fixed in 0.6.23.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-39397?

2 open source packages ship an affected version, including @delmaredigital/payload-puck. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@delmaredigital/payload-puck` | npm | All versions | 0.6.23 |
| `@delmaredigital/payload-puck` | npm | All versions | 0.6.23 |

Products: Delmaredigital Payload-Puck.

## How do I fix CVE-2026-39397?

Upgrade @delmaredigital/payload-puck to 0.6.23 or later.

## Is CVE-2026-39397 being exploited?

There is no known exploitation of CVE-2026-39397 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39397 and fix it if it is affected.

What it is: CVE-2026-39397 is a critical missing authorization vulnerability in delmaredigital payload-puck, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39397 in the wild and no public exploit code.

Affected packages and fixed versions:
- @delmaredigital/payload-puck (npm): affected all versions; fixed in 0.6.23
- @delmaredigital/payload-puck (npm): affected all versions; fixed in 0.6.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39397/ (Markdown: https://insights.sbomify.com/CVE-2026-39397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39397
- OSV: https://osv.dev/vulnerability/CVE-2026-39397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39397/
Summaries are generated and may contain mistakes; the official description above is the record.
