# CVE-2026-39401: Privilege Escalation via update_event Job Output in Cronicle

> Low-privilege users can modify any event configuration, including webhooks and emails, by injecting update_event keys in job output, leading to privilege escalation.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-5j3v-cq96-xw6v

## What is CVE-2026-39401?

CVE-2026-39401 is a medium-severity missing authorization vulnerability in jhuckaby Cronicle, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cronicle is a multi-server task scheduler and runner, with a web based front-end UI. Prior to 0.9.111, jb child processes can include an update_event key in their JSON output. The server applies this directly to the parent event's stored configuration without any authorization check. A low-privilege user who can create and run events can modify any event property, including webhook URLs and notification emails. This vulnerability is fixed in 0.9.111.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-39401?

It affects 1 product.


Products: Cronicle Cronicle.

## How do I fix CVE-2026-39401?

No fix has been published for CVE-2026-39401 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-39401 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39401 exists.

## Other vulnerabilities in jhuckaby Cronicle

- [CVE-2026-39400](https://insights.sbomify.com/CVE-2026-39400/): Stored XSS via Job HTML/Table Output in Cronicle (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39401 and fix it if it is affected.

What it is: CVE-2026-39401 is a medium-severity missing authorization vulnerability in jhuckaby Cronicle, published on 7 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39401 exists.

Affected product: jhuckaby Cronicle. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39401/ (Markdown: https://insights.sbomify.com/CVE-2026-39401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39401
- OSV: https://osv.dev/vulnerability/CVE-2026-39401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39401/
Summaries are generated and may contain mistakes; the official description above is the record.
