# CVE-2026-39407: Hono has a middleware bypass via repeated slashes in serveStatic

> Attackers can bypass route-based authorization middleware to access protected static files by using repeated slashes in request paths.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** CLEANSTART-2026-PI04588, CLEANSTART-2026-QM34993, GHSA-wmmm-f939-6g9c, MINI-5gg9-7cgg-fwc7, MINI-9rcg-gqj8-7qq6, MINI-ch98-5rh5-5r6r, MINI-j2gg-532p-r6g8, MINI-qrfh-qfqf-mfj5, MINI-wvch-rc6v-m6c3, MINI-x2mh-xm9m-7926, ROOT-APP-NPM-CVE-2026-39407

## What is CVE-2026-39407?

CVE-2026-39407 is a medium-severity missing authorization vulnerability in honojs hono, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.12, a path handling inconsistency in serveStatic allows protected static files to be accessed by using repeated slashes (//) in the request path. When route-based middleware (e.g., /admin/*) is used for authorization, the router may not match paths containing repeated slashes, while serveStatic resolves them as normalized paths. This can lead to a middleware bypass. This vulnerability is fixed in 4.12.12.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-39407?

2 open source packages ship an affected version, including hono. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hono` | npm | All versions | 4.12.12 |
| `hono` | npm | All versions | 4.12.12 |

Products: Hono Hono.

## How do I fix CVE-2026-39407?

Upgrade hono to 4.12.12 or later.

## Is CVE-2026-39407 being exploited?

There is no known exploitation of CVE-2026-39407 in the wild and no public exploit code.

## Other vulnerabilities in honojs hono

- [CVE-2026-27700](https://insights.sbomify.com/CVE-2026-27700/): Hono is Vulnerable to Authentication Bypass by IP Spoofing in AWS Lambda ALB conninfo (high 8.2)
- [CVE-2026-22817](https://insights.sbomify.com/CVE-2026-22817/): JWT Algorithm Confusion via Unsafe Default (HS256) in Hono JWT Middleware Allows Token Forgery and Auth Bypass (high 8.2)
- [CVE-2026-22818](https://insights.sbomify.com/CVE-2026-22818/): JWT algorithm confusion in Hono JWK Auth Middleware when JWK lacks "alg" (untrusted header.alg fallback) (high 8.2)
- [CVE-2025-62610](https://insights.sbomify.com/CVE-2025-62610/): Hono Improperly Authorizes JWT Audience Validation (high 8.1)
- [CVE-2026-29045](https://insights.sbomify.com/CVE-2026-29045/): Hono: Arbitrary file access via serveStatic vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39407 and fix it if it is affected.

What it is: CVE-2026-39407 is a medium-severity missing authorization vulnerability in honojs hono, published on 8 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39407 in the wild and no public exploit code.

Affected packages and fixed versions:
- hono (npm): affected all versions; fixed in 4.12.12
- hono (npm): affected all versions; fixed in 4.12.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39407/ (Markdown: https://insights.sbomify.com/CVE-2026-39407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39407
- OSV: https://osv.dev/vulnerability/CVE-2026-39407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39407/
Summaries are generated and may contain mistakes; the official description above is the record.
