# CVE-2026-39411: LobeHub has an unauthenticated authentication bypass on `webapi` routes via forgeable `X-lobe-chat-auth` header

> Attackers can bypass authentication on protected webapi routes by forging the X-lobe-chat-auth header using a hardcoded XOR key.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-5mwj-v5jw-5c97

## What is CVE-2026-39411?

CVE-2026-39411 is a medium-severity authentication bypass vulnerability in lobehub, published on 8 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

LobeHub is a work-and-lifestyle space to find, build, and collaborate with agent teammates that grow with you. Prior to 2.1.48, the webapi authentication layer trusts a client-controlled X-lobe-chat-auth header that is only XOR-obfuscated, not signed or otherwise authenticated. Because the XOR key is hardcoded in the repository, an attacker can forge arbitrary auth payloads and bypass authentication on protected webapi routes. Affected routes include /webapi/chat/[provider], /webapi/models/[provider], /webapi/models/[provider]/pull, and /webapi/create-image/comfyui. This vulnerability is fixed in 2.1.48.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-290 (Authentication Bypass by Spoofing), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-39411?

2 open source packages ship an affected version, including @lobehub/lobehub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@lobehub/lobehub` | npm | All versions | 2.1.48 |
| `@lobehub/lobehub` | npm | All versions | 2.1.48 |

Products: Lobehub Lobehub.

## How do I fix CVE-2026-39411?

Upgrade @lobehub/lobehub to 2.1.48 or later.

## Is CVE-2026-39411 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39411 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39411 and fix it if it is affected.

What it is: CVE-2026-39411 is a medium-severity authentication bypass vulnerability in lobehub, published on 8 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39411 exists.

Affected packages and fixed versions:
- @lobehub/lobehub (npm): affected all versions; fixed in 2.1.48
- @lobehub/lobehub (npm): affected all versions; fixed in 2.1.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39411/ (Markdown: https://insights.sbomify.com/CVE-2026-39411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39411
- OSV: https://osv.dev/vulnerability/CVE-2026-39411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39411/
Summaries are generated and may contain mistakes; the official description above is the record.
