# CVE-2026-39416: Stored XSS in modal item preview for long item content in AIL Framework

> Attackers can execute arbitrary JavaScript in authenticated users' browsers via stored XSS in the modal item preview of the AIL Framework.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Apr 2026
- **Updated:** 9 Apr 2026
- **Also known as:** GHSA-fj6v-43r7-gcjm

## What is CVE-2026-39416?

CVE-2026-39416 is a high-severity cross-site scripting vulnerability in ail-project ail-framework, published on 8 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

AIL framework is an open-source platform to collect, crawl, process and analyse unstructured data. Prior to 6.8, a stored cross-site scripting (XSS) vulnerability was identified in the modal item preview functionality. When item content longer than 800 characters was processed, attacker-controlled content was returned without an explicit text/plain content type, allowing the browser to interpret the response as active HTML. This could result in execution of arbitrary JavaScript in the context of an authenticated user viewing a crafted item. This vulnerability is fixed in 6.8.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-39416?

It affects 1 product.


Products: Circl Ail Framework.

## How do I fix CVE-2026-39416?

No fix has been published for CVE-2026-39416 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-39416 being exploited?

There is no known exploitation of CVE-2026-39416 in the wild and no public exploit code.

## Other vulnerabilities in ail-project ail-framework

- [CVE-2020-8545](https://insights.sbomify.com/CVE-2020-8545/): Path traversal in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39416 and fix it if it is affected.

What it is: CVE-2026-39416 is a high-severity cross-site scripting vulnerability in ail-project ail-framework, published on 8 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39416 in the wild and no public exploit code.

Affected product: ail-project ail-framework. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39416/ (Markdown: https://insights.sbomify.com/CVE-2026-39416/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39416
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39416
- OSV: https://osv.dev/vulnerability/CVE-2026-39416

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39416/
Summaries are generated and may contain mistakes; the official description above is the record.
