# CVE-2026-39422: MaxKB has Stored XSS via ChatHeadersMiddleware

> Attackers can inject malicious scripts via application name or icon fields, leading to arbitrary JavaScript execution in victims' browsers.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-wf7p-3jq5-q52w

## What is CVE-2026-39422?

CVE-2026-39422 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 14 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

MaxKB is an open-source AI assistant for enterprise. Versions 2.7.1 and below contain a Stored Cross-Site Scripting (XSS) vulnerability through the application name or icon fields when creating an application. When a victim visits the public chat interface (/ui/chat/{access_token}), the ChatHeadersMiddleware retrieves the application data and directly inserts the unescaped application name and icon into the HTML response via string replacement. This allows an attacker to execute arbitrary JavaScript in the victim's browser context. This issue has been fixed in version 2.8.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-39422?

It affects 1 product.


Products: Maxkb Maxkb.

## How do I fix CVE-2026-39422?

No fix has been published for CVE-2026-39422 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-39422 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39422 exists.

## Other vulnerabilities in 1Panel-dev MaxKB

- [CVE-2025-66419](https://insights.sbomify.com/CVE-2025-66419/): MaxKB vulnerable to privilege escalation through sandbox bypass (high 8.8)
- [CVE-2025-66446](https://insights.sbomify.com/CVE-2025-66446/): MaxKB has a Python sandbox LD_PRELOAD bypass (high 8.8)
- [CVE-2025-64511](https://insights.sbomify.com/CVE-2025-64511/): MaxKB has SSRF in sandbox (high 7.4)
- [CVE-2026-39423](https://insights.sbomify.com/CVE-2026-39423/): Stored XSS via Eval Injection in EchartsRander Component (medium 6.9)
- [CVE-2024-56137](https://insights.sbomify.com/CVE-2024-56137/): MaxKB RCE vulnerability in function library (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39422 and fix it if it is affected.

What it is: CVE-2026-39422 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 14 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39422 exists.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39422/ (Markdown: https://insights.sbomify.com/CVE-2026-39422/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39422
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39422
- OSV: https://osv.dev/vulnerability/CVE-2026-39422

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39422/
Summaries are generated and may contain mistakes; the official description above is the record.
