# CVE-2026-39425: MaxKB: Stored XSS via Unsanitized html_rander Tags in Markdown Rendering

> Authenticated users can inject malicious scripts into chatbot prologues, leading to session hijacking and data exposure for visitors.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 14 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-3rq5-pgm7-pvp4

## What is CVE-2026-39425?

CVE-2026-39425 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 14 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

MaxKB is an open-source AI assistant for enterprise. Versions 2.7.1 and below contain a Stored Cross-Site Scripting (XSS) vulnerability that allows authenticated users to inject arbitrary HTML and JavaScript into the Application prologue (Opening Remarks) field by wrapping malicious payloads in <html_rander> tags. The backend fails to sanitize or encode HTML entities in the prologue field when applications are created or updated via the /admin/api/workspace/{workspace_id}/application endpoint, storing the raw payload directly in the database. The frontend then renders this content using an innerHTML-equivalent mechanism, trusting <html_rander>-wrapped content to be safe, which enables persistent DOM-based Stored XSS execution against any visitor who opens the affected chatbot interface. Exploitation can lead to session hijacking, unauthorized actions performed on behalf of victims (such as deleting workspaces or applications), and sensitive data exposure. This issue has been fixed in version 2.8.0.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2026-39425?

It affects 1 product.


Products: Maxkb Maxkb.

## How do I fix CVE-2026-39425?

No fix has been published for CVE-2026-39425 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-39425 being exploited?

There is no known exploitation of CVE-2026-39425 in the wild and no public exploit code.

## Other vulnerabilities in 1Panel-dev MaxKB

- [CVE-2025-66419](https://insights.sbomify.com/CVE-2025-66419/): MaxKB vulnerable to privilege escalation through sandbox bypass (high 8.8)
- [CVE-2025-66446](https://insights.sbomify.com/CVE-2025-66446/): MaxKB has a Python sandbox LD_PRELOAD bypass (high 8.8)
- [CVE-2025-64511](https://insights.sbomify.com/CVE-2025-64511/): MaxKB has SSRF in sandbox (high 7.4)
- [CVE-2026-39422](https://insights.sbomify.com/CVE-2026-39422/): MaxKB has Stored XSS via ChatHeadersMiddleware (medium 6.9)
- [CVE-2026-39423](https://insights.sbomify.com/CVE-2026-39423/): Stored XSS via Eval Injection in EchartsRander Component (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39425 and fix it if it is affected.

What it is: CVE-2026-39425 is a medium-severity cross-site scripting vulnerability in 1Panel-dev MaxKB, published on 14 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-39425 in the wild and no public exploit code.

Affected product: 1Panel-dev MaxKB. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39425/ (Markdown: https://insights.sbomify.com/CVE-2026-39425/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39425
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39425
- OSV: https://osv.dev/vulnerability/CVE-2026-39425

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39425/
Summaries are generated and may contain mistakes; the official description above is the record.
