{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-3945 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-3945 is a high-severity vulnerability in tinyproxy, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-3945 and fix it if it is affected.\n\nWhat it is: CVE-2026-3945 is a high-severity vulnerability in tinyproxy, published on 30 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-3945 in the wild and no public exploit code.\n\nAffected product: tinyproxy. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-3945/ (Markdown: https://insights.sbomify.com/CVE-2026-3945/index.md)","id":"CVE-2026-3945","markdown":"https://insights.sbomify.com/CVE-2026-3945/index.md","name":"CVE-2026-3945","record":{"aliases":["DEBIAN-CVE-2026-3945","GHSA-6vhj-8f7g-v7f7","UBUNTU-CVE-2026-3945","openSUSE-SU-2026:10471-1","openSUSE-SU-2026:20456-1"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HTTP proxy server","requires_auth":"none","summary":"An unauthenticated remote attacker can cause a denial of service in tinyproxy via an integer overflow in the HTTP chunked transfer encoding parser.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"TuranSec","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"An integer overflow vulnerability in the HTTP chunked transfer encoding parser in tinyproxy up to and including version 1.11.3 allows an unauthenticated remote attacker to cause a denial of service (DoS). The issue occurs because chunk size values are parsed using strtol without properly validating overflow conditions (e.g., errno == ERANGE).","ecosystems":["openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"tinyproxy Integer Overflow in HTTP Chunked Transfer-Encoding Parser Leading to Denial of Service","id":"CVE-2026-3945","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2026"},"n_packages":2,"n_references":5,"next":{"headline":"PHPEMS index.php cross site scripting","id":"CVE-2026-3946"},"packages":[{"ecosystem":"openSUSE:Leap 16.0","fixed":["1.11.3-bp160.1.1"],"introduced":["0"],"last_affected":[],"package":"tinyproxy","purl":"pkg:rpm/opensuse/tinyproxy\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:20456-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.11.3-2.1"],"introduced":["0"],"last_affected":[],"package":"tinyproxy","purl":"pkg:rpm/opensuse/tinyproxy\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:10471-1"}],"prev":{"headline":"itsourcecode University Management System att_add.php sql injection","id":"CVE-2026-3944"},"products":["tinyproxy"],"published":"2026-03-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-10","vendors":["tinyproxy"]},"summary":"An unauthenticated remote attacker can cause a denial of service in tinyproxy via an integer overflow in the HTTP chunked transfer encoding parser.","url":"https://insights.sbomify.com/CVE-2026-3945/"}