# CVE-2026-3965: whyour qinglong API express.ts protection mechanism


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 11 Mar 2026
- **Updated:** 12 Mar 2026
- **Also known as:** GHSA-xj37-qjg2-xwv2

## What is CVE-2026-3965?

CVE-2026-3965 is a medium-severity vulnerability in whyour qinglong, published on 11 Mar 2026. 

### Official description

A security vulnerability has been detected in whyour qinglong up to 2.20.1. Affected is an unknown function of the file back/loaders/express.ts of the component API Interface. The manipulation of the argument command leads to protection mechanism failure. The attack may be initiated remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 2.20.2 is able to address this issue. The identifier of the patch is 6bec52dca158481258315ba0fc2f11206df7b719. It is advisable to upgrade the affected component. The code maintainer was informed beforehand about the issues. He reacted very fast and highly professional.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-3965?

2 open source packages ship an affected version, including @whyour/qinglong.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@whyour/qinglong` | npm | All versions | 2.20.2 |
| `@whyour/qinglong` | npm | All versions | 2.20.2 |

## How do I fix CVE-2026-3965?

Upgrade @whyour/qinglong to 2.20.2 or later.

## Is CVE-2026-3965 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-3965 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-3965 and fix it if it is affected.

What it is: CVE-2026-3965 is a medium-severity vulnerability in whyour qinglong, published on 11 Mar 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-3965 exists.

Affected packages and fixed versions:
- @whyour/qinglong (npm): affected all versions; fixed in 2.20.2
- @whyour/qinglong (npm): affected all versions; fixed in 2.20.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-3965/ (Markdown: https://insights.sbomify.com/CVE-2026-3965/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-3965
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-3965
- OSV: https://osv.dev/vulnerability/CVE-2026-3965

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-3965/
Summaries are generated and may contain mistakes; the official description above is the record.
