# CVE-2026-39816: Apache NiFi: Missing Execute Code Required Permission on TinkerpopClientService

> Users without Execute Code permission can execute Groovy scripts via TinkerpopClientService in Apache NiFi installations with fine-grained authorization and the optional graph services extension.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L/AU:Y/R:I/V:C/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 May 2026
- **Updated:** 9 May 2026
- **Also known as:** BIT-nifi-2026-39816, GHSA-2j9m-25xv-mp6r, MINI-3hc4-25m5-cfpx

## What is CVE-2026-39816?

CVE-2026-39816 is a high-severity missing authorization vulnerability in Apache Nifi, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The optional extension component TinkerpopClientService is missing the Restricted annotation with the Execute Code Required Permission in Apache NiFi 2.0.0-M1 through 2.8.0. The TinkerpopClientService supports configuration of ByteCode Submission for the Script Submission Type, enabling Groovy Script execution in the service prior to submitting the query. The missing Restricted annotation allows users without the Execute Code Permission to configure the Service in installations that use fine-grained authorization and have the optional TinkerpopClientService installed. Apache NiFi installations that do not have the nifi-other-graph-services-nar installed are not subject to this vulnerability. Upgrading to Apache NiFi 2.9.0 is the recommended mitigation.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-39816?

3 open source packages ship an affected version, including org.apache.nifi:nifi-other-graph-services-nar and nifi. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.nifi:nifi-other-graph-services-nar` | Maven | From 2.0.0-M1 | 2.9.0 |
| `org.apache.nifi:nifi-other-graph-services-nar` | Maven | From 2.0.0-M1 | 2.9.0 |
| `nifi` | Bitnami | From 2.0.0 | 2.9.0 |

Products: Apache Nifi.

## How do I fix CVE-2026-39816?

Upgrade org.apache.nifi:nifi-other-graph-services-nar to 2.9.0 or later.

## Is CVE-2026-39816 being exploited?

There is no known exploitation of CVE-2026-39816 in the wild and no public exploit code.

Public exploit code:

- POC for CVE-2026-39816 which allows NiFi users without execute code permissions to run arbitrary scripts (github_poc): https://github.com/ZeroPathAI/nifi-CVE-2026-39816-poc

## Other vulnerabilities in Apache Nifi

- [CVE-2018-1309](https://insights.sbomify.com/CVE-2018-1309/): Improper Restriction of XML External Entity Reference in Apache NiFi (critical 9.8)
- [CVE-2017-15697](https://insights.sbomify.com/CVE-2017-15697/): Apache NiFi XSS issue in context path handling (critical 9.8)
- [CVE-2017-5636](https://insights.sbomify.com/CVE-2017-5636/): Injection in Apache NiFi (critical 9.8)
- [CVE-2026-68981](https://insights.sbomify.com/CVE-2026-68981/): Apache NiFi: Uncontrolled Resource Consumption through Decompression of HTTP Requests (high 8.8)
- [CVE-2023-36542](https://insights.sbomify.com/CVE-2023-36542/): Apache NiFi: Potential Code Injection with Properties Referencing Remote Resources (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39816 and fix it if it is affected.

What it is: CVE-2026-39816 is a high-severity missing authorization vulnerability in Apache Nifi, published on 8 May 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39816 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.nifi:nifi-other-graph-services-nar (Maven): affected from 2.0.0-M1; fixed in 2.9.0
- org.apache.nifi:nifi-other-graph-services-nar (Maven): affected from 2.0.0-M1; fixed in 2.9.0
- nifi (Bitnami): affected from 2.0.0; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39816/ (Markdown: https://insights.sbomify.com/CVE-2026-39816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39816
- OSV: https://osv.dev/vulnerability/CVE-2026-39816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39816/
Summaries are generated and may contain mistakes; the official description above is the record.
