CVE-2026-39842 OpenRemote is Vulnerable to Expression Injection

Critical 10.0 Published Updated

Attackers with write:rules role can inject JavaScript or Groovy code to execute arbitrary commands as root, bypassing sandbox restrictions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-39842?

CVE-2026-39842 is a critical code injection vulnerability in openremote, published on 14 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

OpenRemote is an open-source IoT platform. Versions 1.21.0 and below contain two interrelated expression injection vulnerabilities in the rules engine that allow arbitrary code execution on the server. The JavaScript rules engine executes user-supplied scripts via Nashorn's ScriptEngine.eval() without sandboxing, class filtering, or access restrictions, and the authorization check in RulesResourceImpl only restricts Groovy rules to superusers while leaving JavaScript rules unrestricted for any user with the write:rules role. Additionally, the Groovy rules engine has a GroovyDenyAllFilter security filter that is defined but never registered, as the registration code is commented out, rendering the SandboxTransformer ineffective for superuser-created Groovy rules. A non-superuser attacker with the write:rules role can create JavaScript rulesets that execute with full JVM access, enabling remote code execution as root, arbitrary file read, environment variable theft including database credentials, and complete multi-tenant isolation bypass to access data across all realms. This issue has been fixed in version 1.22.0.

Weakness: CWE-94, CWE-917

Which versions are affected by CVE-2026-39842?

2 open source packages ship an affected version, including io.openremote:openremote-manager. It affects 1 product.

PackageAffectedFixed in
io.openremote:openremote-manager MavenAll versions1.22.0
io.openremote:openremote-manager MavenAll versions1.22.0

Products include Openremote Openremote.

How do I fix CVE-2026-39842?

Upgrade io.openremote:openremote-manager to 1.22.0 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-39842 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39842 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as GHSA-7mqr-33rv-p3mp.

Is CVE-2026-39842 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free