# CVE-2026-39842: OpenRemote is Vulnerable to Expression Injection

> Attackers with write:rules role can inject JavaScript or Groovy code to execute arbitrary commands as root, bypassing sandbox restrictions.

- **Severity:** Critical 10.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-7mqr-33rv-p3mp

## What is CVE-2026-39842?

CVE-2026-39842 is a critical code injection vulnerability in openremote, published on 14 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenRemote is an open-source IoT platform. Versions 1.21.0 and below contain two interrelated expression injection vulnerabilities in the rules engine that allow arbitrary code execution on the server. The JavaScript rules engine executes user-supplied scripts via Nashorn's ScriptEngine.eval() without sandboxing, class filtering, or access restrictions, and the authorization check in RulesResourceImpl only restricts Groovy rules to superusers while leaving JavaScript rules unrestricted for any user with the write:rules role. Additionally, the Groovy rules engine has a GroovyDenyAllFilter security filter that is defined but never registered, as the registration code is commented out, rendering the SandboxTransformer ineffective for superuser-created Groovy rules. A non-superuser attacker with the write:rules role can create JavaScript rulesets that execute with full JVM access, enabling remote code execution as root, arbitrary file read, environment variable theft including database credentials, and complete multi-tenant isolation bypass to access data across all realms. This issue has been fixed in version 1.22.0.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-917 (Improper Neutralization of Special Elements used in an Expression Language Statement)

## Which versions are affected by CVE-2026-39842?

2 open source packages ship an affected version, including io.openremote:openremote-manager. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.openremote:openremote-manager` | Maven | All versions | 1.22.0 |
| `io.openremote:openremote-manager` | Maven | All versions | 1.22.0 |

Products: Openremote Openremote.

## How do I fix CVE-2026-39842?

Upgrade io.openremote:openremote-manager to 1.22.0 or later.

## Is CVE-2026-39842 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39842 exists.

Public exploit code:

- Critical remote code execution vulnerability in OpenRemote's Rules Engine allows authenticated users with `write:rules` role to execute arbitrary code on the server with root privileges. (github_poc): https://github.com/keraattin/CVE-2026-39842

## Other vulnerabilities in openremote

- [CVE-2022-31860](https://insights.sbomify.com/CVE-2022-31860/): Code injection in n/a (critical 9.8)
- [CVE-2026-40882](https://insights.sbomify.com/CVE-2026-40882/): OpenRemote has XXE in Velbus Asset Import (high 7.6)
- [CVE-2026-62238](https://insights.sbomify.com/CVE-2026-62238/): OpenRemote < 1.26.0 SQL Injection via Crosstab Export (high 7.2)
- [CVE-2026-41166](https://insights.sbomify.com/CVE-2026-41166/): OpenRemote has Improper Access Control via updateUserRealmRoles function (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39842 and fix it if it is affected.

What it is: CVE-2026-39842 is a critical code injection vulnerability in openremote, published on 14 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39842 exists.

Affected packages and fixed versions:
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.22.0
- io.openremote:openremote-manager (Maven): affected all versions; fixed in 1.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39842/ (Markdown: https://insights.sbomify.com/CVE-2026-39842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39842
- OSV: https://osv.dev/vulnerability/CVE-2026-39842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39842/
Summaries are generated and may contain mistakes; the official description above is the record.
