# CVE-2026-39847: Emmett has a path traversal in internal assets handler

> An attacker can read arbitrary files outside the assets directory via path traversal in the internal assets handler of the Emmett Python web framework.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Apr 2026
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-pr46-2v3c-5356, PYSEC-2026-59

## What is CVE-2026-39847?

CVE-2026-39847 is a critical path traversal vulnerability in emmett-framework emmett, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Emmett is a full-stack Python web framework designed with simplicity. From 2.5.0 to before 2.8.1, the RSGI static handler for Emmett's internal assets (/__emmett__ paths) is vulnerable to path traversal attacks. An attacker can use ../ sequences (eg /__emmett__/../rsgi/handlers.py) to read arbitrary files outside the assets directory. This vulnerability is fixed in 2.8.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-39847?

3 open source packages ship an affected version, including emmett. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `emmett` | PyPI | From 2.5.0 | 2.8.1 |
| `emmett` | PyPI | From 2.5.0 | 2.8.1 |
| `emmett` | PyPI | From 2.5.0 | 2.8.1 |

Products: Emmett Emmett.

## How do I fix CVE-2026-39847?

Upgrade emmett to 2.8.1 or later.

## Is CVE-2026-39847 being exploited?

There is no known exploitation of CVE-2026-39847 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39847 and fix it if it is affected.

What it is: CVE-2026-39847 is a critical path traversal vulnerability in emmett-framework emmett, published on 7 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39847 in the wild and no public exploit code.

Affected packages and fixed versions:
- emmett (PyPI): affected from 2.5.0; fixed in 2.8.1
- emmett (PyPI): affected from 2.5.0; fixed in 2.8.1
- emmett (PyPI): affected from 2.5.0; fixed in 2.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39847/ (Markdown: https://insights.sbomify.com/CVE-2026-39847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39847
- OSV: https://osv.dev/vulnerability/CVE-2026-39847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39847/
Summaries are generated and may contain mistakes; the official description above is the record.
