{"answers":{"affected":"2 open source packages ship an affected version, including yiisoft/yii2.","exploited":"There is no known exploitation of CVE-2026-39850 in the wild and no public exploit code.","fix":"Upgrade yiisoft/yii2 to 2.0.55 or later.","what":"CVE-2026-39850 is a high-severity path traversal vulnerability in yiisoft yii2, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-39850 and fix it if it is affected.\n\nWhat it is: CVE-2026-39850 is a high-severity path traversal vulnerability in yiisoft yii2, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-39850 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- yiisoft/yii2 (Packagist): affected all versions; fixed in 2.0.55\n- yiisoft/yii2 (Packagist): affected all versions; fixed in 2.0.55\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-39850/ (Markdown: https://insights.sbomify.com/CVE-2026-39850/index.md)","id":"CVE-2026-39850","markdown":"https://insights.sbomify.com/CVE-2026-39850/index.md","name":"CVE-2026-39850","record":{"aliases":["CLSA-2026-1787002033","GHSA-5vpg-rj7q-qpw2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP application framework","requires_auth":"none","summary":"Attackers can exploit a variable collision in Yii 2's view rendering to include arbitrary local files, potentially leading to remote code execution or information disclosure.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-98","name":"Improper Control of Filename for Include/Require Statement in PHP Program"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Yii 2 is a PHP application framework. Versions 2.0.54 and prior contain flawed logic in the core view rendering method View::renderPhpFile() that leads to Local File Inclusion. The function calls extract($_params_, EXTR_OVERWRITE) before the require statement that loads the view file. As a result, a caller-controlled _file_ key in the $params array overwrites the internal local variable specifying which file to include, potentially enabling RCE if an attacker can write PHP files through a separate primitive, as well as information disclosure. This issue has been fixed in version 2.0.55.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Yii 2: Local file inclusion via view parameter name collision","id":"CVE-2026-39850","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"Saleor has a user enumeration vulnerability due to different error messages","id":"CVE-2026-39851"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.55"],"introduced":["0"],"last_affected":[],"package":"yiisoft/yii2","purl":null,"source":"GHSA-5vpg-rj7q-qpw2"},{"ecosystem":"Packagist","fixed":["2.0.55"],"introduced":["0"],"last_affected":[],"package":"yiisoft/yii2","purl":"pkg:composer/yiisoft/yii2","source":"GHSA-5vpg-rj7q-qpw2"}],"prev":{"headline":"Pi-hole FTL remote code execution via newline injection in dns.interface configuration","id":"CVE-2026-39849"},"products":["yii2"],"published":"2026-05-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-21","vendors":["yiisoft"]},"summary":"Attackers can exploit a variable collision in Yii 2's view rendering to include arbitrary local files, potentially leading to remote code execution or information disclosure.","url":"https://insights.sbomify.com/CVE-2026-39850/"}