# CVE-2026-39850: Yii 2: Local file inclusion via view parameter name collision

> Attackers can exploit a variable collision in Yii 2's view rendering to include arbitrary local files, potentially leading to remote code execution or information disclosure.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 May 2026
- **Updated:** 21 May 2026
- **Also known as:** CLSA-2026-1787002033, GHSA-5vpg-rj7q-qpw2

## What is CVE-2026-39850?

CVE-2026-39850 is a high-severity path traversal vulnerability in yiisoft yii2, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yii 2 is a PHP application framework. Versions 2.0.54 and prior contain flawed logic in the core view rendering method View::renderPhpFile() that leads to Local File Inclusion. The function calls extract($_params_, EXTR_OVERWRITE) before the require statement that loads the view file. As a result, a caller-controlled _file_ key in the $params array overwrites the internal local variable specifying which file to include, potentially enabling RCE if an attacker can write PHP files through a separate primitive, as well as information disclosure. This issue has been fixed in version 2.0.55.

Weakness: CWE-98 (Improper Control of Filename for Include/Require Statement in PHP Program), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-39850?

2 open source packages ship an affected version, including yiisoft/yii2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2` | Packagist | All versions | 2.0.55 |
| `yiisoft/yii2` | Packagist | All versions | 2.0.55 |

## How do I fix CVE-2026-39850?

Upgrade yiisoft/yii2 to 2.0.55 or later.

## Is CVE-2026-39850 being exploited?

There is no known exploitation of CVE-2026-39850 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39850 and fix it if it is affected.

What it is: CVE-2026-39850 is a high-severity path traversal vulnerability in yiisoft yii2, published on 20 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-39850 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii2 (Packagist): affected all versions; fixed in 2.0.55
- yiisoft/yii2 (Packagist): affected all versions; fixed in 2.0.55

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39850/ (Markdown: https://insights.sbomify.com/CVE-2026-39850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39850
- OSV: https://osv.dev/vulnerability/CVE-2026-39850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39850/
Summaries are generated and may contain mistakes; the official description above is the record.
