# CVE-2026-39857: Information Disclosure via `choices`/`counts` Query Parameters Bypassing publicApiProjection Field Restrictions

> Unauthenticated attackers can bypass field restrictions in ApostropheCMS to extract sensitive distinct values and counts from the database via query parameters.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 16 Apr 2026
- **Also known as:** GHSA-c276-fj82-f2pq

## What is CVE-2026-39857?

CVE-2026-39857 is a medium-severity vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ApostropheCMS is an open-source Node.js content management system. Versions 4.28.0 and prior contain an authorization bypass vulnerability in the choices and counts query parameters of the REST API, where these query builders execute MongoDB distinct() operations that bypass the publicApiProjection restrictions intended to limit which fields are exposed publicly. The choices and counts parameters are processed via applyBuildersSafely before the projection is applied, and MongoDB's distinct operation does not respect projections, returning all distinct values directly. The results are returned in the API response without any filtering against publicApiProjection or removeForbiddenFields. An unauthenticated attacker can extract all distinct field values for any schema field type that has a registered query builder, including string, integer, float, select, boolean, date, slug, and relationship fields. Fields protected with viewPermission are similarly exposed, and the counts variant additionally reveals how many documents have each distinct value. Both the piece-type and page REST APIs are affected. This issue has been fixed in version 4.29.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-39857?

2 open source packages ship an affected version, including apostrophe. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apostrophe` | npm | All versions | 4.29.0 |
| `apostrophe` | npm | All versions | 4.29.0 |

Products: Apostrophecms Apostrophecms.

## How do I fix CVE-2026-39857?

Upgrade apostrophe to 4.29.0 or later.

## Is CVE-2026-39857 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39857 exists.

## Other vulnerabilities in apostrophecms apostrophe

- [CVE-2021-25979](https://insights.sbomify.com/CVE-2021-25979/): Apostrophe - Insufficient Session Expiration (critical 9.8)
- [CVE-2026-35569](https://insights.sbomify.com/CVE-2026-35569/): ApostropheCMS: Stored XSS in SEO Fields Leads to Authenticated API Data Exposure in ApostropheCMS (high 8.7)
- [CVE-2026-32730](https://insights.sbomify.com/CVE-2026-32730/): ApostropheCMS MFA/TOTP Bypass via Incorrect MongoDB Query in Bearer Token Middleware (high 8.1)
- [CVE-2026-40186](https://insights.sbomify.com/CVE-2026-40186/): ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements (medium 6.1)
- [CVE-2026-33889](https://insights.sbomify.com/CVE-2026-33889/): ApostropheCMS: Stored XSS via CSS Custom Property Injection in `@apostrophecms/color-field` Escaping Style Tag Context (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-39857 and fix it if it is affected.

What it is: CVE-2026-39857 is a medium-severity vulnerability in apostrophecms apostrophe, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-39857 exists.

Affected packages and fixed versions:
- apostrophe (npm): affected all versions; fixed in 4.29.0
- apostrophe (npm): affected all versions; fixed in 4.29.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-39857/ (Markdown: https://insights.sbomify.com/CVE-2026-39857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-39857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-39857
- OSV: https://osv.dev/vulnerability/CVE-2026-39857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-39857/
Summaries are generated and may contain mistakes; the official description above is the record.
